CVE-2017-7559 — undertow-core
MEDIUMCVE-2017-7559 is a medium-severity (CVSS 6.1) CWE-444 vulnerability in io.undertow:undertow-core. A fix is available for io.undertow:undertow-core — see the affected versions and patch details below.
Undertow vulnerable to Request Smuggling
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
How urgent is this, really
Where this sits among everything scored
Real-World Exposure
io.undertow:undertow-core☕io.undertow:undertow-core☕io.undertow:undertow-coreReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects Maven packages — download data is not available via public APIs for these ecosystems.
Description
In Undertow 2.x before 2.0.0.Alpha2, 1.4.x before 1.4.17.Final, and 1.3.x before 1.3.31.Final, it was found that the fix for CVE-2017-2666 was incomplete and invalid characters are still allowed in the query string and path parameters. This could be exploited, in conjunction with a proxy that also permitted the invalid characters but with a different interpretation, to inject data into the HTTP response. By manipulating the HTTP response the attacker could poison a web-cache, perform an XSS attack, or obtain sensitive information from requests other than their own.
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| ☕Maven | io.undertow:undertow-core | ≥ 1.4.0&&< 1.4.17.Final | 1.4.17.Finalio.undertow:undertow-core:1.4.17.Final |
| ☕Maven | io.undertow:undertow-core | ≥ 1.3.0&&< 1.3.31.Final | 1.3.31.Finalio.undertow:undertow-core:1.3.31.Final |
| ☕Maven | io.undertow:undertow-core | ≥ 2.0.0.Alpha1&&< 2.0.0.Alpha2 | 2.0.0.Alpha2io.undertow:undertow-core:2.0.0.Alpha2 |
Affected Products
undertowredhatDetection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for io.undertow:undertow-core, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update io.undertow:undertow-core to 1.4.17.Final or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2017-7559 is resolved across your whole dependency graph.
Workarounds
Escape or sanitise the affected output on the server side rather than relying on client-side filtering, and add a Content-Security-Policy that blocks inline script execution so injected markup cannot run even if it reaches the page.
Fixing This On Your OS
If you run this on a Linux distribution, patch through your package manager against the distro's own security advisory below — it tracks the exact backported fix for your release, which can ship on a different timeline (and sometimes a different severity) than the upstream project.
| Product | Fixed in | Advisory |
|---|---|---|
| Red Hat JBoss A-MQ 6.3 | see advisory | RHSA-2018:1322 |
| Red Hat JBoss EAP 7.0 | wildfly-undertow | RHSA-2018:0003 |
| Red Hat JBoss EAP 7.1 | see advisory | RHSA-2017:3456 |
| Red Hat JBoss Enterprise Application Platform 7.0 for RHEL 6 | eap7-activemq-artemis-0:1.1.0-19.SP24_redhat_1.1.ep7.el6 | RHSA-2018:0002 |
| Red Hat JBoss Enterprise Application Platform 7.0 for RHEL 6 | eap7-jboss-ec2-eap-0:7.0.9-2.GA_redhat_2.ep7.el6 | RHSA-2018:0005 |
| Red Hat JBoss Enterprise Application Platform 7.0 for RHEL 7 | eap7-activemq-artemis-0:1.1.0-19.SP24_redhat_1.1.ep7.el7 | RHSA-2018:0004 |
| Red Hat JBoss Enterprise Application Platform 7.1 for RHEL 6 | eap7-activemq-artemis-0:1.5.5.008-1.redhat_1.1.ep7.el6 | RHSA-2017:3454 |
| Red Hat JBoss Enterprise Application Platform 7.1 for RHEL 6 | eap7-jboss-ec2-eap-0:7.1.0-5.GA_redhat_5.ep7.el6 | RHSA-2017:3458 |
Frequently Asked Questions
Is CVE-2017-7559 in your dependencies?
Find it across Maven, including transitive dependencies.