NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
🐘
🐘 Packagist
Not in CISA KEV
MEDIUM severity

CVE-2017-7532 — moodle

MEDIUMFix: moodle/moodle@6e861be

CVE-2017-7532 is a medium-severity (CVSS 6.5) Improper Privilege Management vulnerability in moodle/moodle. A fix is available for moodle/moodle — see the affected versions and patch details below.

Moodle Improper Privilege Management

Also known asGHSA-jjhx-5jff-rc8m
Published
Updated
Affected
3 pkgs
Patched
3 / 3
Exploits
None indexed
Exploitation data as of Nov 1, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

EPSS Exploitation Probability

via FIRST.org ↗
1.0%probability of exploitation in next 30 days
Lower Risk+0.11%
Lower risk than most CVEs62th percentile — riskier than 62% of all scored CVEsHighest risk
0.00%0.49%0.99%1.48%0.1%1.0%May 26Aug 26Nov 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

3 pkgs affected
🐘moodle/moodle🐘moodle/moodle🐘moodle/moodle

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects Packagist packages — download data is not available via public APIs for these ecosystems.

Description

In Moodle 3.x, course creators are able to change system default settings for courses.

Affected Packages

3 total 3 fixed
EcosystemPackageVulnerable rangeFix
🐘Packagistmoodle/moodle≥ 3.3.0&&< 3.3.13.3.1composer require moodle/moodle:^3.3.1
🐘Packagistmoodle/moodle≥ 3.2.0&&< 3.2.43.2.4composer require moodle/moodle:^3.2.4
🐘Packagistmoodle/moodleall versions3.1.7composer require moodle/moodle:^3.1.7

Affected Products

1 product · 22 configurations
Application
moodlemoodle
13 versions
3.1.03.1.13.1.23.1.33.1.43.1.53.1.63.2.03.2.13.2.23.2.33.3.0

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for moodle/moodle, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update moodle/moodle to 3.3.1 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2017-7532 is resolved across your whole dependency graph.

  3. Workarounds

    Close the privilege gap rather than the entry point: audit which accounts, roles and service identities can reach the affected operation, drop the component to the least privilege it actually needs, and review file and directory permissions created by earlier installs — a default left in place is what makes this reachable.

Frequently Asked Questions

In Moodle 3.x, course creators are able to change system default settings for courses.
O3 Security · Impact-Aware SCA

Is CVE-2017-7532 in your dependencies?

Find it across Packagist, including transitive dependencies.

CVE-2017-7532: moodle — Fixed in 3.3.1