NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
🐘
🐘 Packagist
Not in CISA KEV
MEDIUM severity

CVE-2017-7490 — moodle

MEDIUM

CVE-2017-7490 is a medium-severity (CVSS 5.3) CWE-668 vulnerability in moodle/moodle. A fix is available for moodle/moodle — see the affected versions and patch details below.

Moodle Unauthorized searching of arbitrary blogs by typing full url

Also known asGHSA-9x63-m3cc-qf3g
Published
Updated
Affected
4 pkgs
Patched
4 / 4
Exploits
None indexed
Exploitation data as of Nov 6, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

EPSS Exploitation Probability

via FIRST.org ↗
1.0%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs64th percentile — riskier than 64% of all scored CVEsHighest risk
0.00%0.52%1.03%1.55%0.3%1.0%May 26Sep 26Nov 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

4 pkgs affected
🐘moodle/moodle🐘moodle/moodle🐘moodle/moodle🐘moodle/moodle

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects Packagist packages — download data is not available via public APIs for these ecosystems.

Description

In Moodle 2.x and 3.x, searching of arbitrary blogs is possible because a capability check is missing.

Affected Packages

4 total 4 fixed
EcosystemPackageVulnerable rangeFix
🐘Packagistmoodle/moodle≥ 3.2&&< 3.2.33.2.3composer require moodle/moodle:^3.2.3
🐘Packagistmoodle/moodle≥ 3.1&&< 3.1.63.1.6composer require moodle/moodle:^3.1.6
🐘Packagistmoodle/moodle≥ 3.0&&< 3.0.103.0.10composer require moodle/moodle:^3.0.10
🐘Packagistmoodle/moodle≥ 2.7&&< 2.7.202.7.20composer require moodle/moodle:^2.7.20

Affected Products

1 product · 53 configurations
Application
moodlemoodle
36 versions
2.7.02.7.12.7.22.7.32.7.42.7.52.7.62.7.72.7.82.7.92.7.102.7.11

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for moodle/moodle, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update moodle/moodle to 3.2.3 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2017-7490 is resolved across your whole dependency graph.

  3. Workarounds

    If you can't upgrade right away: gate or disable the affected feature, validate untrusted input at the boundary, and avoid passing attacker-controlled data into the vulnerable path. O3's runtime protection blocks exploitation in production as an interim safeguard until the upgrade lands.

Frequently Asked Questions

In Moodle 2.x and 3.x, searching of arbitrary blogs is possible because a capability check is missing.
O3 Security · Impact-Aware SCA

Is CVE-2017-7490 in your dependencies?

Find it across Packagist, including transitive dependencies.

CVE-2017-7490: moodle — Fixed in 3.2.3