CVE-2017-7297 — rancher
HIGHCVE-2017-7297 is a high-severity (CVSS 8.8) vulnerability in github.com/rancher/rancher. A fix is available for github.com/rancher/rancher — see the affected versions and patch details below.
Rancher Access Control Vulnerability
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
How urgent is this, really
Where this sits among everything scored
Real-World Exposure
github.com/rancher/rancher🐹github.com/rancher/rancher🐹github.com/rancher/rancher🐹github.com/rancher/rancherReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects Go packages — download data is not available via public APIs for these ecosystems.
Description
Rancher Labs rancher server 1.2.0+ is vulnerable to authenticated users disabling access control via an API call. This is fixed in versions rancher/server:v1.2.4, rancher/server:v1.3.5, rancher/server:v1.4.3, and rancher/server:v1.5.3.
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| 🐹Go | github.com/rancher/rancher | ≥ 1.5.0&&< 1.5.3 | 1.5.3go get github.com/rancher/rancher@v1.5.3 |
| 🐹Go | github.com/rancher/rancher | ≥ 1.4.0&&< 1.4.3 | 1.4.3go get github.com/rancher/rancher@v1.4.3 |
| 🐹Go | github.com/rancher/rancher | ≥ 1.3.0&&< 1.3.5 | 1.3.5go get github.com/rancher/rancher@v1.3.5 |
| 🐹Go | github.com/rancher/rancher | ≥ 1.2.0&&< 1.2.4 | 1.2.4go get github.com/rancher/rancher@v1.2.4 |
Affected Products
ranchersuseDetection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for github.com/rancher/rancher, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update github.com/rancher/rancher to 1.5.3 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2017-7297 is resolved across your whole dependency graph.
Workarounds
Put an independent control in front of the weakness: restrict the affected endpoint or interface to trusted networks, require an additional authentication factor or proxy-level check, and invalidate existing sessions and credentials in case the flaw has already been used.
Frequently Asked Questions
Is CVE-2017-7297 in your dependencies?
Find it across Go, including transitive dependencies.