NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
🐘
🐘 Packagist
Not in CISA KEV
MEDIUM severity

CVE-2017-6216 — infusionsoft-php-sdk

MEDIUMFix: novaksolutions/infusionsoft-php-sdk@110c06f

CVE-2017-6216 is a medium-severity (CVSS 6.1) Cross-site Scripting (XSS) vulnerability in novaksolutions/infusionsoft-php-sdk. 1 public exploit or proof-of-concept reference is indexed, so weaponization risk is real. A fix is available for novaksolutions/infusionsoft-php-sdk — see the affected versions and patch details below.

infusionsoft-php-sdk reflected Cross-site Scripting

Also known asGHSA-8jmj-4p32-mc9p
Published
Updated
Affected
1 pkg
Patched
1 / 1
Exploits
1 known
Exploitation data as of Nov 3, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

EPSS Exploitation Probability

via FIRST.org ↗
1.2%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs69th percentile — riskier than 69% of all scored CVEsHighest risk
0.00%0.58%1.16%1.74%0.4%1.2%May 26Sep 26Nov 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

1 pkg affected
🐘novaksolutions/infusionsoft-php-sdk

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects Packagist packages — download data is not available via public APIs for these ecosystems.

Description

novaksolutions/infusionsoft-php-sdk before v1.0 is vulnerable to a reflected XSS in the leadscoring.php via ContactId parameter.

Affected Packages

1 total 1 fixed
EcosystemPackageVulnerable rangeFix
🐘Packagistnovaksolutions/infusionsoft-php-sdkall versions1.0composer require novaksolutions/infusionsoft-php-sdk:^1.0

Affected Products

1 product · 1 configurations
Application
infusionsoft-php-sdknovaksolutions
1 version
2016-10-31
Exploits & PoCs
1

Research use only. For defensive security, authorized penetration testing, and academic research only. Never execute exploit code against systems without explicit written authorization.

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for novaksolutions/infusionsoft-php-sdk, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update novaksolutions/infusionsoft-php-sdk to 1.0 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2017-6216 is resolved across your whole dependency graph.

  3. Workarounds

    Escape or sanitise the affected output on the server side rather than relying on client-side filtering, and add a Content-Security-Policy that blocks inline script execution so injected markup cannot run even if it reaches the page.

Frequently Asked Questions

novaksolutions/infusionsoft-php-sdk before v1.0 is vulnerable to a reflected XSS in the `leadscoring.php` via `ContactId` parameter.
O3 Security · Impact-Aware SCA

Is CVE-2017-6216 in your dependencies?

Find it across Packagist, including transitive dependencies.

CVE-2017-6216: infusionsoft-php-sdk XSS — Fixed in 1.0