NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
🐘
🐘 Packagist
Not in CISA KEV
MEDIUM severity

CVE-2017-6099 — merchant-sdk-php

MEDIUM

CVE-2017-6099 is a medium-severity (CVSS 6.1) Cross-site Scripting (XSS) vulnerability in paypal/merchant-sdk-php. 1 public exploit or proof-of-concept reference is indexed, so weaponization risk is real. A fix is available for paypal/merchant-sdk-php — see the affected versions and patch details below.

PayPal PHP Merchant SDK Cross-site scripting (XSS) vulnerability

Also known asGHSA-p4g7-wjhq-9r2h
Published
Updated
Affected
1 pkg
Patched
1 / 1
Exploits
1 known
Exploitation data as of Nov 6, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

EPSS Exploitation Probability

via FIRST.org ↗
1.2%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs69th percentile — riskier than 69% of all scored CVEsHighest risk
0.00%0.58%1.16%1.74%0.2%1.2%May 26Sep 26Nov 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

1 pkg affected
🐘paypal/merchant-sdk-php

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects Packagist packages — download data is not available via public APIs for these ecosystems.

Description

Cross-site scripting (XSS) vulnerability in GetAuthDetails.html.php in PayPal PHP Merchant SDK (aka merchant-sdk-php) 3.9.1 allows remote attackers to inject arbitrary web script or HTML via the token parameter.

Affected Packages

1 total 1 fixed
EcosystemPackageVulnerable rangeFix
🐘Packagistpaypal/merchant-sdk-php≥ 3.0.0&&< 3.12.03.12.0composer require paypal/merchant-sdk-php:^3.12.0

Affected Products

1 product · 1 configurations
Application
merchant-sdk-phppaypal
1 version
3.9.1
Exploits & PoCs
1

Research use only. For defensive security, authorized penetration testing, and academic research only. Never execute exploit code against systems without explicit written authorization.

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for paypal/merchant-sdk-php, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update paypal/merchant-sdk-php to 3.12.0 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2017-6099 is resolved across your whole dependency graph.

  3. Workarounds

    Escape or sanitise the affected output on the server side rather than relying on client-side filtering, and add a Content-Security-Policy that blocks inline script execution so injected markup cannot run even if it reaches the page.

Frequently Asked Questions

Cross-site scripting (XSS) vulnerability in GetAuthDetails.html.php in PayPal PHP Merchant SDK (aka merchant-sdk-php) 3.9.1 allows remote attackers to inject arbitrary web script or HTML via the token parameter.
O3 Security · Impact-Aware SCA

Is CVE-2017-6099 in your dependencies?

Find it across Packagist, including transitive dependencies.

CVE-2017-6099: merchant-sdk-php XSS — Fixed in 3.12.0