CVE-2017-5992 — openpyxl
HIGHCVE-2017-5992 is a high-severity (CVSS 8.2) XML External Entity (XXE) vulnerability in openpyxl. A fix is available for openpyxl — see the affected versions and patch details below.
Improper Restriction of XML External Entity Reference in Openpyxl
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
How urgent is this, really
Where this sits among everything scored
Real-World Exposure
openpyxlReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects PyPI packages — download data is not available via public APIs for these ecosystems.
Description
Openpyxl 2.4.1 resolves external entities by default, which allows remote attackers to conduct XXE attacks via a crafted .xlsx document.
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| 🐍PyPI | openpyxl | all versions | 2.4.2pip install --upgrade 'openpyxl==2.4.2' |
Affected Products
openpyxlpythonDetection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for openpyxl, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update openpyxl to 2.4.2 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2017-5992 is resolved across your whole dependency graph.
Workarounds
If you can't upgrade right away: gate or disable the affected feature, validate untrusted input at the boundary, and avoid passing attacker-controlled data into the vulnerable path. O3's runtime protection blocks exploitation in production as an interim safeguard until the upgrade lands.
Frequently Asked Questions
Is CVE-2017-5992 in your dependencies?
Find it across PyPI, including transitive dependencies.