NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
🐍
🐍 PyPI
Not in CISA KEV
HIGH severity

CVE-2017-5936 — nova-lxd

HIGHFix: openstack/nova-lxd@1b76cef

CVE-2017-5936 is a high-severity (CVSS 7.5) vulnerability in nova-lxd. A fix is available for nova-lxd — see the affected versions and patch details below.

OpenStack Nova-LXD bypass security restrictions

Also known asGHSA-6xc7-4cx8-j3xcPYSEC-2017-21
Published
Updated
Affected
1 pkg
Patched
1 / 1
Exploits
None indexed
Exploitation data as of Nov 5, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

EPSS Exploitation Probability

via FIRST.org ↗
2.9%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs87th percentile — riskier than 87% of all scored CVEsHighest risk
1.97%2.46%2.95%3.43%2.5%2.9%May 26Sep 26Nov 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

1 pkg affected
🐍nova-lxd

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects PyPI packages — download data is not available via public APIs for these ecosystems.

Description

OpenStack Nova-LXD before 13.1.1 uses the wrong name for the veth pairs when applying Neutron security group rules for instances, which allows remote attackers to bypass intended security restrictions.

Affected Packages

1 total 1 fixed
EcosystemPackageVulnerable rangeFix
🐍PyPInova-lxdall versions13.1.1pip install --upgrade 'nova-lxd==13.1.1'

Affected Products

2 products · 2 configurations
OS
ubuntu linuxcanonical
1 version
16.04
Application
nova-lxdopenstack
≤ 13.1.0
range

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for nova-lxd, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update nova-lxd to 13.1.1 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2017-5936 is resolved across your whole dependency graph.

  3. Workarounds

    If you can't upgrade right away: gate or disable the affected feature, validate untrusted input at the boundary, and avoid passing attacker-controlled data into the vulnerable path. O3's runtime protection blocks exploitation in production as an interim safeguard until the upgrade lands.

Frequently Asked Questions

OpenStack Nova-LXD before 13.1.1 uses the wrong name for the veth pairs when applying Neutron security group rules for instances, which allows remote attackers to bypass intended security restrictions.
O3 Security · Impact-Aware SCA

Is CVE-2017-5936 in your dependencies?

Find it across PyPI, including transitive dependencies.

CVE-2017-5936: nova-lxd — Fixed in 13.1.1