CVE-2017-5647 is a high-severity (CVSS 7.5) Information Exposure vulnerability in org.apache.tomcat:tomcat. EPSS puts its 30-day exploitation probability at 16.8% (97th percentile). A fix is available for org.apache.tomcat:tomcat — see the affected versions and patch details below.
Exposure of Sensitive Information to an Unauthorized Actor in Apache Tomcat
Exploitation Status
No confirmed exploitation observed yet
- CISA’s own triage has not observed active exploitation or public proof-of-concept code for this CVE as of its last assessment.
Exploitation and automatability from CISA’s SSVC triage for CVE-2017-5647.
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
How urgent is this, really
Where this sits among everything scored
Real-World Exposure
org.apache.tomcat:tomcat☕org.apache.tomcat:tomcat☕org.apache.tomcat:tomcat☕org.apache.tomcat:tomcat☕org.apache.tomcat:tomcatReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects Maven packages — download data is not available via public APIs for these ecosystems.
Description
A bug in the handling of the pipelined requests in Apache Tomcat 9.0.0.M1 to 9.0.0.M18, 8.5.0 to 8.5.12, 8.0.0.RC1 to 8.0.42, 7.0.0 to 7.0.76, and 6.0.0 to 6.0.52, when send file was used, results in the pipelined request being lost when send file processing of the previous request completed. This could result in responses appearing to be sent for the wrong request. For example, a user agent that sent requests A, B and C could see the correct response for request A, the response for request C for request B and no response for request C.
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| ☕Maven | org.apache.tomcat:tomcat | ≥ 9.0.0.M1&&< 9.0.0.M19 | 9.0.0.M19org.apache.tomcat:tomcat:9.0.0.M19 |
| ☕Maven | org.apache.tomcat:tomcat | ≥ 8.5.0&&< 8.5.13 | 8.5.13org.apache.tomcat:tomcat:8.5.13 |
| ☕Maven | org.apache.tomcat:tomcat | ≥ 8.0.0&&< 8.0.43 | 8.0.43org.apache.tomcat:tomcat:8.0.43 |
| ☕Maven | org.apache.tomcat:tomcat | ≥ 7.0.0&&< 7.0.77 | 7.0.77org.apache.tomcat:tomcat:7.0.77 |
| ☕Maven | org.apache.tomcat:tomcat | ≥ 6.0.0&&< 6.0.53 | 6.0.53org.apache.tomcat:tomcat:6.0.53 |
Affected Products
tomcatapacheDetection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for org.apache.tomcat:tomcat, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update org.apache.tomcat:tomcat to 9.0.0.M19 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2017-5647 is resolved across your whole dependency graph.
Workarounds
Assume what was exposed is already known: rotate any credential, token or key that the affected component could return, restrict the endpoint to callers that genuinely need it, and strip sensitive fields from responses and error output at the boundary rather than relying on the client not to read them.
Fixing This On Your OS
If you run this on a Linux distribution, patch through your package manager against the distro's own security advisory below — it tracks the exact backported fix for your release, which can ship on a different timeline (and sometimes a different severity) than the upstream project.
The AJP connector does not support the sendfile capability. A server configured to only use the AJP connector (disable HTTP Connector) is not affected by this vulnerability. Disable the sendfile capability by setting useSendfile="false" in the HTTP connector configuration. Note: Disabling sendfile, may impact performance on large files.Source: Red Hat security advisory for CVE-2017-5647 (CC BY 4.0)
| Product | Fixed in | Advisory |
|---|---|---|
| Red Hat Enterprise Linux 6 | tomcat6-0:6.0.24-111.el6_9 | RHSA-2017:3080 |
| Red Hat Enterprise Linux 7 | tomcat-0:7.0.76-3.el7_4 | RHSA-2017:3081 |
| Red Hat JBoss Enterprise Web Server 2 for RHEL 6 | jbcs-httpd24-openssl-1:1.0.2h-13.jbcs.el6 | RHSA-2017:2493 |
| Red Hat JBoss Web Server 2.1 | tomcat6 | RHSA-2017:2494 |
| Red Hat JBoss Web Server 3.1 | see advisory | RHSA-2017:1802 |
| Red Hat JBoss Web Server 3 for RHEL 6 | log4j-eap6-0:1.2.16-12.redhat_3.1.ep6.el6 | RHSA-2017:1801 |
Frequently Asked Questions
Is CVE-2017-5647 in your dependencies?
Find it across Maven, including transitive dependencies.