CVE-2017-5646 is a medium-severity (CVSS 6.8) CWE-346 vulnerability in org.apache.knox:gateway-provider-identity-assertion-common. A fix is available for org.apache.knox:gateway-provider-identity-assertion-common — see the affected versions and patch details below.
Apache Knox allows impersonation of users
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
How urgent is this, really
Where this sits among everything scored
Real-World Exposure
org.apache.knox:gateway-provider-identity-assertion-commonReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects Maven packages — download data is not available via public APIs for these ecosystems.
Description
For versions of Apache Knox from 0.2.0 to 0.11.0 - an authenticated user may use a specially crafted URL to impersonate another user while accessing WebHDFS through Apache Knox. This may result in escalated privileges and unauthorized data access. While this activity is audit logged and can be easily associated with the authenticated user, this is still a serious security issue. All users are recommended to upgrade to the Apache Knox 0.12.0 release.
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| ☕Maven | org.apache.knox:gateway-provider-identity-assertion-common | ≥ 0.2.0&&< 0.12.0 | 0.12.0org.apache.knox:gateway-provider-identity-assertion-common:0.12.0 |
Affected Products
knoxapacheDetection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for org.apache.knox:gateway-provider-identity-assertion-common, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update org.apache.knox:gateway-provider-identity-assertion-common to 0.12.0 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2017-5646 is resolved across your whole dependency graph.
Workarounds
If you can't upgrade right away: gate or disable the affected feature, validate untrusted input at the boundary, and avoid passing attacker-controlled data into the vulnerable path. O3's runtime protection blocks exploitation in production as an interim safeguard until the upgrade lands.
Frequently Asked Questions
Is CVE-2017-5646 in your dependencies?
Find it across Maven, including transitive dependencies.