CVE-2017-5591 is a medium-severity (CVSS 5.9) Improper Input Validation vulnerability in slixmpp. 3 public exploit or proof-of-concept references are indexed, so weaponization risk is real. A fix is available for slixmpp — see the affected versions and patch details below.
SleekXMPP and Slixmpp Incorrect Implementation of Message Carbons
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
How urgent is this, really
Where this sits among everything scored
Real-World Exposure
slixmpp🐍sleekxmppReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects PyPI packages — download data is not available via public APIs for these ecosystems.
Description
An incorrect implementation of "XEP-0280: Message Carbons" in multiple XMPP clients allows a remote attacker to impersonate any user, including contacts, in the vulnerable application's display. This allows for various kinds of social engineering attacks. This CVE is for SleekXMPP up to 1.3.1 and Slixmpp all versions up to 1.2.3, as bundled in poezio (0.8 - 0.10) and other products.
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| 🐍PyPI | slixmpp | all versions | 1.2.4pip install --upgrade 'slixmpp==1.2.4' |
| 🐍PyPI | sleekxmpp | all versions | 1.3.2pip install --upgrade 'sleekxmpp==1.3.2' |
Affected Products
poeziopoeziosleekxmppsleekxmpp_projectslixmppslixmpp_projectResearch use only. For defensive security, authorized penetration testing, and academic research only. Never execute exploit code against systems without explicit written authorization.
Detection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for slixmpp, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update slixmpp to 1.2.4 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2017-5591 is resolved across your whole dependency graph.
Workarounds
If you can't upgrade right away: gate or disable the affected feature, validate untrusted input at the boundary, and avoid passing attacker-controlled data into the vulnerable path. O3's runtime protection blocks exploitation in production as an interim safeguard until the upgrade lands.
Frequently Asked Questions
Is CVE-2017-5591 in your dependencies?
Find it across PyPI, including transitive dependencies.