CVE-2017-5543 is a critical-severity (CVSS 9.8) Code Injection vulnerability in intelliants/subrion. A fix is available for intelliants/subrion — see the affected versions and patch details below.
Subrion CMS PHP Object Injection
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
How urgent is this, really
Where this sits among everything scored
Real-World Exposure
intelliants/subrionReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects Packagist packages — download data is not available via public APIs for these ecosystems.
Description
includes/classes/ia.core.users.php in Subrion CMS 4.0.5 allows remote attackers to conduct PHP Object Injection attacks via crafted serialized data in a salt cookie in a login request.
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| 🐘Packagist | intelliants/subrion | ≥ 4.0.5&&< 4.1.0 | 4.1.0composer require intelliants/subrion:^4.1.0 |
Affected Products
subrionintelliantsDetection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for intelliants/subrion, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update intelliants/subrion to 4.1.0 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2017-5543 is resolved across your whole dependency graph.
Workarounds
Stop passing untrusted input into the interpreter or shell: call the affected binary with an argument array rather than a composed command string, reject anything outside a strict allowlist of expected values, and run the component under an account that cannot reach beyond the work it legitimately does.
Frequently Asked Questions
Is CVE-2017-5543 in your dependencies?
Find it across Packagist, including transitive dependencies.