NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
🐍
🐍 PyPI
Not in CISA KEV
HIGH severity

CVE-2017-5192 — salt

HIGH

CVE-2017-5192 is a high-severity (CVSS 8.8) Improper Authentication vulnerability in salt. A fix is available for salt — see the affected versions and patch details below.

SaltStack Salt Authentication Bypass when using the local_batch client from salt-api

Also known asGHSA-f2h7-4f84-8qrmPYSEC-2017-38
Published
Updated
Affected
3 pkgs
Patched
3 / 3
Exploits
None indexed
Exploitation data as of Nov 5, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

EPSS Exploitation Probability

via FIRST.org ↗
1.7%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs77th percentile — riskier than 77% of all scored CVEsHighest risk
0.00%0.73%1.46%2.20%0.1%1.7%May 26Sep 26Nov 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

3 pkgs affected
🐍salt🐍salt🐍salt

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects PyPI packages — download data is not available via public APIs for these ecosystems.

Description

When using the local_batch client from salt-api in SaltStack Salt before 2015.8.13, 2016.3.x before 2016.3.5, and 2016.11.x before 2016.11.2, external authentication is not respected, enabling all authentication to be bypassed.

Affected Packages

3 total 3 fixed
EcosystemPackageVulnerable rangeFix
🐍PyPIsaltall versions2015.8.13pip install --upgrade 'salt==2015.8.13'
🐍PyPIsalt≥ 2016.3.0&&< 2016.3.52016.3.5pip install --upgrade 'salt==2016.3.5'
🐍PyPIsalt≥ 2016.11.0&&< 2016.11.22016.11.2pip install --upgrade 'salt==2016.11.2'

Affected Products

1 product · 9 configurations
Application
saltsaltstack
≤ 2015.8.12
8 versions
2016.3.02016.3.12016.3.22016.3.32016.3.42016.11.02016.11.12016.11.2

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for salt, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update salt to 2015.8.13 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2017-5192 is resolved across your whole dependency graph.

  3. Workarounds

    Put an independent control in front of the weakness: restrict the affected endpoint or interface to trusted networks, require an additional authentication factor or proxy-level check, and invalidate existing sessions and credentials in case the flaw has already been used.

Fixing This On Your OS

If you run this on a Linux distribution, patch through your package manager against the distro's own security advisory below — it tracks the exact backported fix for your release, which can ship on a different timeline (and sometimes a different severity) than the upstream project.

Red HatModerate

This issue did not affect the versions of the salt as shipped with Red Hat Ceph Storage 1.3, Red Hat Ceph Storage 2, and Red Hat Storage Console 2 as salt-api and salt-ssh are not shipped with these products.

Workaround published by Red Hat
Disable salt-api for mitigation.
Source: Red Hat security advisory for CVE-2017-5192 (CC BY 4.0)

Frequently Asked Questions

When using the local_batch client from salt-api in SaltStack Salt before 2015.8.13, 2016.3.x before 2016.3.5, and 2016.11.x before 2016.11.2, external authentication is not respected, enabling all authentication to be bypassed.
O3 Security · Impact-Aware SCA

Is CVE-2017-5192 in your dependencies?

Find it across PyPI, including transitive dependencies.

CVE-2017-5192: salt — Fixed in 2015.8.13