CVE-2017-3153 — atlas-common
MEDIUMCVE-2017-3153 is a medium-severity (CVSS 6.1) Cross-site Scripting (XSS) vulnerability in org.apache.atlas:atlas-common. A fix is available for org.apache.atlas:atlas-common — see the affected versions and patch details below.
Cross-site Scripting in Apache Atlas
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
How urgent is this, really
Where this sits among everything scored
Real-World Exposure
org.apache.atlas:atlas-commonReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects Maven packages — download data is not available via public APIs for these ecosystems.
Description
Apache Atlas versions 0.6.0-incubating and 0.7.0-incubating were found vulnerable to Reflected XSS in the search functionality.
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| ☕Maven | org.apache.atlas:atlas-common | ≥ 0.6.0-incubating&&< 0.7.1-incubating | 0.7.1-incubatingorg.apache.atlas:atlas-common:0.7.1-incubating |
Affected Products
atlasapacheDetection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for org.apache.atlas:atlas-common, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update org.apache.atlas:atlas-common to 0.7.1-incubating or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2017-3153 is resolved across your whole dependency graph.
Workarounds
Escape or sanitise the affected output on the server side rather than relying on client-side filtering, and add a Content-Security-Policy that blocks inline script execution so injected markup cannot run even if it reaches the page.
Frequently Asked Questions
Is CVE-2017-3153 in your dependencies?
Find it across Maven, including transitive dependencies.