NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
💎
💎 RubyGems
Not in CISA KEV
HIGH severity

CVE-2017-2667 — hammer_cli_foreman

HIGH

CVE-2017-2667 is a high-severity (CVSS 8.1) CWE-345 vulnerability in hammer_cli_foreman. A fix is available for hammer_cli_foreman — see the affected versions and patch details below.

hammer_cli_foreman Improper Certificate Validation vulnerability

Also known asGHSA-77h8-xr85-3x5q
Published
Updated
Affected
1 pkg
Patched
1 / 1
Exploits
None indexed
Exploitation data as of Nov 4, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

EPSS Exploitation Probability

via FIRST.org ↗
0.7%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs53th percentile — riskier than 53% of all scored CVEsHighest risk
0.00%0.41%0.82%1.23%0.1%0.7%May 26Sep 26Nov 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

1 pkg affected
💎hammer_cli_foreman

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects RubyGems packages — download data is not available via public APIs for these ecosystems.

Description

Hammer CLI, a CLI utility for Foreman, before version 0.10.0, did not explicitly set the verify_ssl flag for apipie-bindings that disable it by default. As a result the server certificates are not checked and connections are prone to man-in-the-middle attacks.

Affected Packages

1 total 1 fixed
EcosystemPackageVulnerable rangeFix
💎RubyGemshammer_cli_foremanall versions0.10.0bundle update hammer_cli_foreman --conservative

Affected Products

3 products · 3 configurations
Application
satelliteredhat
1 version
6.3
Application
satellite capsuleredhat
1 version
6.3
Application
hammer clitheforeman
< 0.10.0
range

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for hammer_cli_foreman, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update hammer_cli_foreman to 0.10.0 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2017-2667 is resolved across your whole dependency graph.

  3. Workarounds

    If you can't upgrade right away: gate or disable the affected feature, validate untrusted input at the boundary, and avoid passing attacker-controlled data into the vulnerable path. O3's runtime protection blocks exploitation in production as an interim safeguard until the upgrade lands.

Fixing This On Your OS

If you run this on a Linux distribution, patch through your package manager against the distro's own security advisory below — it tracks the exact backported fix for your release, which can ship on a different timeline (and sometimes a different severity) than the upstream project.

Red HatModerate

This issue affects the versions of rubygem-hammer_cli as shipped with Red Hat Enterprise Linux 6 and 7. Red Hat Product Security has rated this issue as having security impact of Moderate. A future update may address this issue. For additional information, refer to the Issue Severity Classification:…

ProductFixed inAdvisory
Red Hat Satellite 6.3 for RHEL 7candlepin-0:2.1.14-1.el7RHSA-2018:0336

Frequently Asked Questions

Hammer CLI, a CLI utility for Foreman, before version 0.10.0, did not explicitly set the verify_ssl flag for apipie-bindings that disable it by default. As a result the server certificates are not checked and connections are prone to man-in-the-middle attacks.
O3 Security · Impact-Aware SCA

Is CVE-2017-2667 in your dependencies?

Find it across RubyGems, including transitive dependencies.

CVE-2017-2667: hammer_cli_foreman — Fixed in 0.10.0