CVE-2017-2641 — moodle
CRITICALCVE-2017-2641 is a critical-severity (CVSS 9.8) SQL Injection vulnerability in moodle/moodle. 3 public exploit or proof-of-concept references are indexed, so weaponization risk is real. A fix is available for moodle/moodle — see the affected versions and patch details below.
Moodle SQL injection via user preferences
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
How urgent is this, really
Where this sits among everything scored
Real-World Exposure
moodle/moodle🐘moodle/moodle🐘moodle/moodle🐘moodle/moodleReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects Packagist packages — download data is not available via public APIs for these ecosystems.
Description
In Moodle 2.x and 3.x, SQL injection can occur via user preferences.
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| 🐘Packagist | moodle/moodle | ≥ 2.7&&< 2.7.19 | 2.7.19composer require moodle/moodle:^2.7.19 |
| 🐘Packagist | moodle/moodle | ≥ 3.0&&< 3.0.9 | 3.0.9composer require moodle/moodle:^3.0.9 |
| 🐘Packagist | moodle/moodle | ≥ 3.1&&< 3.1.5 | 3.1.5composer require moodle/moodle:^3.1.5 |
| 🐘Packagist | moodle/moodle | ≥ 3.2&&< 3.2.2 | 3.2.2composer require moodle/moodle:^3.2.2 |
Affected Products
moodlemoodleResearch use only. For defensive security, authorized penetration testing, and academic research only. Never execute exploit code against systems without explicit written authorization.
Moodle 2.x/3.x - SQL Injection
by Marko Belzetski · Apr 6, 2017
Detection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for moodle/moodle, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update moodle/moodle to 2.7.19 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2017-2641 is resolved across your whole dependency graph.
Workarounds
Until you can upgrade, make sure every query built from user input uses parameterised statements or a prepared-statement API rather than string concatenation, and reduce the database account's privileges so an injected query cannot read or alter data beyond what the feature needs.
Frequently Asked Questions
Is CVE-2017-2641 in your dependencies?
Find it across Packagist, including transitive dependencies.