CVE-2017-2578 — moodle
MEDIUMCVE-2017-2578 is a medium-severity (CVSS 6.1) Cross-site Scripting (XSS) vulnerability in moodle/moodle. A fix is available for moodle/moodle — see the affected versions and patch details below.
Moodle Cross-site Scripting in assignment submission page
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
How urgent is this, really
Where this sits among everything scored
Real-World Exposure
moodle/moodle🐘moodle/moodleReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects Packagist packages — download data is not available via public APIs for these ecosystems.
Description
In Moodle 3.x, there is Cross-site Scripting in the assignment submission page.
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| 🐘Packagist | moodle/moodle | ≥ 3.1&&< 3.1.4 | 3.1.4composer require moodle/moodle:^3.1.4 |
| 🐘Packagist | moodle/moodle | ≥ 3.2&&< 3.2.1 | 3.2.1composer require moodle/moodle:^3.2.1 |
Affected Products
moodlemoodleDetection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for moodle/moodle, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update moodle/moodle to 3.1.4 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2017-2578 is resolved across your whole dependency graph.
Workarounds
Escape or sanitise the affected output on the server side rather than relying on client-side filtering, and add a Content-Security-Policy that blocks inline script execution so injected markup cannot run even if it reaches the page.
Frequently Asked Questions
Is CVE-2017-2578 in your dependencies?
Find it across Packagist, including transitive dependencies.