NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
💎
💎 RubyGems
Not in CISA KEV
CRITICAL severity

CVE-2017-2096 — smalruby-editor

CRITICAL

CVE-2017-2096 is a critical-severity (CVSS 9.8) OS Command Injection vulnerability in smalruby-editor. A fix is available for smalruby-editor — see the affected versions and patch details below.

smalruby and smalruby-editor vulnerable to OS Command Injection

Also known asGHSA-f489-655r-x6gr
Published
Updated
Affected
2 pkgs
Patched
2 / 2
Exploits
None indexed
Exploitation data as of Nov 2, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

EPSS Exploitation Probability

via FIRST.org ↗
6.2%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs94th percentile — riskier than 94% of all scored CVEsHighest risk
4.17%5.00%5.84%6.68%4.7%6.2%May 26Sep 26Nov 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

2 pkgs affected
💎smalruby-editor💎smalruby

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects RubyGems packages — download data is not available via public APIs for these ecosystems.

Description

smalruby-editor prior to 0.4.1 and smalruby prior to 0.1.11 allows remote attackers to execute arbitrary OS commands via unspecified vectors.

Affected Packages

2 total 2 fixed
EcosystemPackageVulnerable rangeFix
💎RubyGemssmalruby-editorall versions0.4.1bundle update smalruby-editor --conservative
💎RubyGemssmalrubyall versions0.1.11bundle update smalruby --conservative

Affected Products

1 product · 1 configurations
Application
smalruby-editorsmalruby
≤ 0.4.0
range

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for smalruby-editor, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update smalruby-editor to 0.4.1 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2017-2096 is resolved across your whole dependency graph.

  3. Workarounds

    Stop passing untrusted input into the interpreter or shell: call the affected binary with an argument array rather than a composed command string, reject anything outside a strict allowlist of expected values, and run the component under an account that cannot reach beyond the work it legitimately does.

Frequently Asked Questions

smalruby-editor prior to 0.4.1 and smalruby prior to 0.1.11 allows remote attackers to execute arbitrary OS commands via unspecified vectors.
O3 Security · Impact-Aware SCA

Is CVE-2017-2096 in your dependencies?

Find it across RubyGems, including transitive dependencies.

CVE-2017-2096: smalruby-editor — Fixed in 0.4.1