CVE-2017-20158 is a medium-severity (CVSS 6.1) Cross-site Scripting (XSS) vulnerability in vova07/yii2-fileapi-widget. A fix is available for vova07/yii2-fileapi-widget — see the affected versions and patch details below.
Yii2 FileAPI Widget vulnerable to Cross-site Scripting
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
How urgent is this, really
Where this sits among everything scored
Real-World Exposure
vova07/yii2-fileapi-widgetReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects Packagist packages — download data is not available via public APIs for these ecosystems.
Description
** UNSUPPORTED WHEN ASSIGNED ** A vulnerability was found in vova07 Yii2 FileAPI Widget up to 0.1.8. It has been declared as problematic. Affected by this vulnerability is the function run of the file actions/UploadAction.php. The manipulation of the argument file leads to cross site scripting. The attack can be launched remotely. Upgrading to version 0.1.9 is able to address this issue. The identifier of the patch is c00d1e4fc912257fca1fce66d7a163bdbb4c8222. It is recommended to upgrade the affected component. The identifier VDB-217141 was assigned to this vulnerability. NOTE: This vulnerability only affects products that are no longer supported by the maintainer.
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| 🐘Packagist | vova07/yii2-fileapi-widget | all versions | 0.1.9composer require vova07/yii2-fileapi-widget:^0.1.9 |
Affected Products
yii2 fileapi widgetyii2_fileapi_widget_projectDetection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for vova07/yii2-fileapi-widget, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update vova07/yii2-fileapi-widget to 0.1.9 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2017-20158 is resolved across your whole dependency graph.
Workarounds
Escape or sanitise the affected output on the server side rather than relying on client-side filtering, and add a Content-Security-Policy that blocks inline script execution so injected markup cannot run even if it reaches the page.
Frequently Asked Questions
Is CVE-2017-20158 in your dependencies?
Find it across Packagist, including transitive dependencies.