NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
🐹
🐹 Go
Not in CISA KEV
MEDIUM severity

CVE-2017-18902 — mattermost-server

MEDIUM

CVE-2017-18902 is a medium-severity (CVSS 5.3) Information Exposure vulnerability in github.com/mattermost/mattermost-server. A fix is available for github.com/mattermost/mattermost-server — see the affected versions and patch details below.

Mattermost Server exposes team invite IDs through API endpoints

Also known asGHSA-jwfv-5hwq-f97rGO-2025-4185
Published
Updated
Affected
3 pkgs
Patched
3 / 3
Exploits
None indexed
Exploitation data as of Nov 2, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

EPSS Exploitation Probability

via FIRST.org ↗
0.9%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs61th percentile — riskier than 61% of all scored CVEsHighest risk
0.00%0.48%0.95%1.43%0.2%0.9%May 26Sep 26Nov 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

3 pkgs affected
🐹github.com/mattermost/mattermost-server🐹github.com/mattermost/mattermost-server🐹github.com/mattermost/mattermost-server

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects Go packages — download data is not available via public APIs for these ecosystems.

Description

An issue was discovered in Mattermost Server before 4.1.0, 4.0.4, and 3.10.3. It allows attackers to discover team invite IDs via team API endpoints.

Affected Packages

3 total 3 fixed
EcosystemPackageVulnerable rangeFix
🐹Gogithub.com/mattermost/mattermost-serverall versions3.10.3go get github.com/mattermost/mattermost-server@v3.10.3
🐹Gogithub.com/mattermost/mattermost-server≥ 4.0.0&&< 4.0.44.0.4go get github.com/mattermost/mattermost-server@v4.0.4
🐹Gogithub.com/mattermost/mattermost-server≥ 4.0.5-rc1&&< 4.1.04.1.0go get github.com/mattermost/mattermost-server@v4.1.0

Affected Products

1 product · 2 configurations
Application
mattermost servermattermost
≥ 4.0.0 && < 4.0.4
range

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for github.com/mattermost/mattermost-server, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update github.com/mattermost/mattermost-server to 3.10.3 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2017-18902 is resolved across your whole dependency graph.

  3. Workarounds

    Assume what was exposed is already known: rotate any credential, token or key that the affected component could return, restrict the endpoint to callers that genuinely need it, and strip sensitive fields from responses and error output at the boundary rather than relying on the client not to read them.

Frequently Asked Questions

An issue was discovered in Mattermost Server before 4.1.0, 4.0.4, and 3.10.3. It allows attackers to discover team invite IDs via team API endpoints.
O3 Security · Impact-Aware SCA

Is CVE-2017-18902 in your dependencies?

Find it across Go, including transitive dependencies.

CVE-2017-18902: mattermost-server — Fixed in 3.10.3