NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
🐹
🐹 Go
Not in CISA KEV
MEDIUM severity

CVE-2017-18892 — mattermost-server

MEDIUMFix: mattermost/mattermost@4e05fbf

CVE-2017-18892 is a medium-severity (CVSS 6.1) CWE-116 vulnerability in github.com/mattermost/mattermost-server. A fix is available for github.com/mattermost/mattermost-server — see the affected versions and patch details below.

Mattermost Server does not neutralize HTML content in an Email template field

Also known asGHSA-wj5w-qghh-gvqpGO-2026-4317
Published
Updated
Affected
3 pkgs
Patched
3 / 3
Exploits
None indexed
Exploitation data as of Nov 3, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

EPSS Exploitation Probability

via FIRST.org ↗
0.7%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs53th percentile — riskier than 53% of all scored CVEsHighest risk
0.00%0.40%0.79%1.19%0.2%0.7%May 26Sep 26Nov 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

3 pkgs affected
🐹github.com/mattermost/mattermost-server🐹github.com/mattermost/mattermost-server🐹github.com/mattermost/mattermost-server

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects Go packages — download data is not available via public APIs for these ecosystems.

Description

An issue was discovered in Mattermost Server before 4.2.0, 4.1.1, and 4.0.5. E-mail templates can have a field in which HTML content is not neutralized.

Affected Packages

3 total 3 fixed
EcosystemPackageVulnerable rangeFix
🐹Gogithub.com/mattermost/mattermost-serverall versions4.0.5go get github.com/mattermost/mattermost-server@v4.0.5
🐹Gogithub.com/mattermost/mattermost-server≥ 4.1.0&&< 4.1.14.1.1go get github.com/mattermost/mattermost-server@v4.1.1
🐹Gogithub.com/mattermost/mattermost-server≥ 4.2.0-rc1&&< 4.2.04.2.0go get github.com/mattermost/mattermost-server@v4.2.0

Affected Products

1 product · 6 configurations
Application
mattermost servermattermost
≥ 4.1.0 && < 4.1.1
1 version
4.2.0

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for github.com/mattermost/mattermost-server, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update github.com/mattermost/mattermost-server to 4.0.5 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2017-18892 is resolved across your whole dependency graph.

  3. Workarounds

    If you can't upgrade right away: gate or disable the affected feature, validate untrusted input at the boundary, and avoid passing attacker-controlled data into the vulnerable path. O3's runtime protection blocks exploitation in production as an interim safeguard until the upgrade lands.

Frequently Asked Questions

An issue was discovered in Mattermost Server before 4.2.0, 4.1.1, and 4.0.5. E-mail templates can have a field in which HTML content is not neutralized.
O3 Security · Impact-Aware SCA

Is CVE-2017-18892 in your dependencies?

Find it across Go, including transitive dependencies.

CVE-2017-18892: mattermost-server — Fixed in 4.0.5