NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
🐹
🐹 Go
Not in CISA KEV
HIGH severity

CVE-2017-18871 — mattermost-server

HIGH

CVE-2017-18871 is a high-severity (CVSS 7.5) vulnerability in github.com/mattermost/mattermost-server. A fix is available for github.com/mattermost/mattermost-server — see the affected versions and patch details below.

Mattermost Server vulnerable to Denial of Service through `@` character prefix inserted into JavaScript field names

Also known asGHSA-jc6w-8r7f-vmp5GO-2025-4184
Published
Updated
Affected
4 pkgs
Patched
4 / 4
Exploits
None indexed
Exploitation data as of Oct 30, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

EPSS Exploitation Probability

via FIRST.org ↗
1.1%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs66th percentile — riskier than 66% of all scored CVEsHighest risk
0.00%0.54%1.08%1.62%0.5%1.1%Apr 26Aug 26Oct 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

4 pkgs affected
🐹github.com/mattermost/mattermost-server🐹github.com/mattermost/mattermost-server🐹github.com/mattermost/mattermost-server🐹github.com/mattermost/mattermost-server

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects Go packages — download data is not available via public APIs for these ecosystems.

Description

An issue was discovered in Mattermost Server before 4.5.0, 4.4.5, 4.3.4, and 4.2.2. It allows attackers to cause a denial of service (application crash) via an @ character before a JavaScript field name.

Affected Packages

4 total 4 fixed
EcosystemPackageVulnerable rangeFix
🐹Gogithub.com/mattermost/mattermost-serverall versions4.2.2go get github.com/mattermost/mattermost-server@v4.2.2
🐹Gogithub.com/mattermost/mattermost-server≥ 4.3.0-rc1&&< 4.3.44.3.4go get github.com/mattermost/mattermost-server@v4.3.4
🐹Gogithub.com/mattermost/mattermost-server≥ 4.4.0-rc1&&< 4.4.54.4.5go get github.com/mattermost/mattermost-server@v4.4.5
🐹Gogithub.com/mattermost/mattermost-server≥ 4.5.0-rc1&&< 4.5.04.5.0go get github.com/mattermost/mattermost-server@v4.5.0

Affected Products

1 product · 7 configurations
Application
mattermost servermattermost
≥ 4.4.0 && < 4.4.5
1 version
4.5.0

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for github.com/mattermost/mattermost-server, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update github.com/mattermost/mattermost-server to 4.2.2 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2017-18871 is resolved across your whole dependency graph.

  3. Workarounds

    Cap what an attacker can consume: apply request size, rate and timeout limits in front of the affected component, and run it with memory and CPU limits so exhaustion degrades one worker rather than the whole service.

Frequently Asked Questions

An issue was discovered in Mattermost Server before 4.5.0, 4.4.5, 4.3.4, and 4.2.2. It allows attackers to cause a denial of service (application crash) via an @ character before a JavaScript field name.
O3 Security · Impact-Aware SCA

Is CVE-2017-18871 in your dependencies?

Find it across Go, including transitive dependencies.

CVE-2017-18871: mattermost-server DoS — Fixed in 4.2.2