NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
🐘
🐘 Packagist
Not in CISA KEV
MEDIUM severity

CVE-2017-18286 — nzedb

MEDIUMFix: nZEDb/nZEDb#2513

CVE-2017-18286 is a medium-severity (CVSS 5.4) Cross-site Scripting (XSS) vulnerability in nzedb/nzedb. 1 public exploit or proof-of-concept reference is indexed, so weaponization risk is real. A fix is available for nzedb/nzedb — see the affected versions and patch details below.

nZEDb Cross-site Scripting (XSS) in the 404 error page

Also known asGHSA-h847-63fg-vm6c
Published
Updated
Affected
1 pkg
Patched
1 / 1
Exploits
1 known
Exploitation data as of Nov 4, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

EPSS Exploitation Probability

via FIRST.org ↗
0.7%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs54th percentile — riskier than 54% of all scored CVEsHighest risk
0.00%0.41%0.83%1.24%0.2%0.7%May 26Sep 26Nov 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

1 pkg affected
🐘nzedb/nzedb

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects Packagist packages — download data is not available via public APIs for these ecosystems.

Description

nZEDb before 0.8.0.0 has XSS in the 404 error page.

Affected Packages

1 total 1 fixed
EcosystemPackageVulnerable rangeFix
🐘Packagistnzedb/nzedball versions0.8.0.0composer require nzedb/nzedb:^0.8.0.0

Affected Products

1 product · 1 configurations
Application
nzedbnzedb
1 version
0.7.3.3
Exploits & PoCs
1

Research use only. For defensive security, authorized penetration testing, and academic research only. Never execute exploit code against systems without explicit written authorization.

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for nzedb/nzedb, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update nzedb/nzedb to 0.8.0.0 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2017-18286 is resolved across your whole dependency graph.

  3. Workarounds

    Escape or sanitise the affected output on the server side rather than relying on client-side filtering, and add a Content-Security-Policy that blocks inline script execution so injected markup cannot run even if it reaches the page.

Frequently Asked Questions

nZEDb before 0.8.0.0 has XSS in the 404 error page.
O3 Security · Impact-Aware SCA

Is CVE-2017-18286 in your dependencies?

Find it across Packagist, including transitive dependencies.

CVE-2017-18286: nzedb XSS — Fixed in 0.8.0.0