NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
🐹
🐹 Go
Not in CISA KEV
HIGH severity

CVE-2017-17831 — git-lfs

HIGHFix: git-lfs/git-lfs#2242

CVE-2017-17831 is a high-severity (CVSS 8.8) Improper Input Validation vulnerability in github.com/git-lfs/git-lfs. 1 public exploit or proof-of-concept reference is indexed, so weaponization risk is real. A fix is available for github.com/git-lfs/git-lfs — see the affected versions and patch details below.

GitHub Git LFS Arbitrary command execution vulnerability

Also known asGHSA-w4xh-w33p-4v29GO-2021-0073
Published
Updated
Affected
1 pkg
Patched
1 / 1
Exploits
1 known
Exploitation data as of Oct 29, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

EPSS Exploitation Probability

via FIRST.org ↗
3.7%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs90th percentile — riskier than 90% of all scored CVEsHighest risk
0.00%1.52%3.04%4.56%0.7%3.7%Apr 26Aug 26Oct 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

1 pkg affected
🐹github.com/git-lfs/git-lfs

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects Go packages — download data is not available via public APIs for these ecosystems.

Description

GitHub Git LFS before 2.1.1 allows remote attackers to execute arbitrary commands via an ssh URL with an initial dash character in the hostname, located on a url = line in a .lfsconfig file within a repository.

Specific Go Packages Affected

github.com/git-lfs/git-lfs/lfsapi

Affected Packages

1 total 1 fixed
EcosystemPackageVulnerable rangeFix
🐹Gogithub.com/git-lfs/git-lfsall versions2.1.1-0.20170519163204-f913f5f9c7c6go get github.com/git-lfs/git-lfs@v2.1.1-0.20170519163204-f913f5f9c7c6

Affected Products

1 product · 1 configurations
Application
git large file storagegit_large_file_storage_project
< 2.1.1
range
Exploits & PoCs
1

Research use only. For defensive security, authorized penetration testing, and academic research only. Never execute exploit code against systems without explicit written authorization.

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for github.com/git-lfs/git-lfs, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update github.com/git-lfs/git-lfs to 2.1.1-0.20170519163204-f913f5f9c7c6 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2017-17831 is resolved across your whole dependency graph.

  3. Workarounds

    If you can't upgrade right away: gate or disable the affected feature, validate untrusted input at the boundary, and avoid passing attacker-controlled data into the vulnerable path. O3's runtime protection blocks exploitation in production as an interim safeguard until the upgrade lands.

Frequently Asked Questions

GitHub Git LFS before 2.1.1 allows remote attackers to execute arbitrary commands via an ssh URL with an initial dash character in the hostname, located on a `url =` line in a `.lfsconfig` file within a repository. ### Specific Go Packages Affected github.com/git-lfs/git-lfs/lfsapi
O3 Security · Impact-Aware SCA

Is CVE-2017-17831 in your dependencies?

Find it across Go, including transitive dependencies.

CVE-2017-17831: git-lfs — Fix Available