NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
💎
💎 RubyGems
Not in CISA KEV
HIGH severity

CVE-2017-16932 — nokogiri

HIGHFix: GNOME/libxml2@899a5d9

CVE-2017-16932 is a high-severity (CVSS 7.5) CWE-835 vulnerability in nokogiri. A fix is available for nokogiri — see the affected versions and patch details below.

Nokogiri gem, via libxml, is affected by DoS vulnerabilities

Also known asGHSA-x2fm-93ww-ggvx
Published
Updated
Affected
1 pkg
Patched
1 / 1
Exploits
None indexed
Exploitation data as of Nov 5, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

Exploitation Status

No confirmed exploitation observed yet

  • CISA assesses this as automatable — exploitation doesn’t require manual, per-target effort, which raises the odds of mass scanning and opportunistic attacks.
  • CISA’s own triage has not observed active exploitation or public proof-of-concept code for this CVE as of its last assessment.

Exploitation and automatability from CISA’s SSVC triage for CVE-2017-16932.

EPSS Exploitation Probability

via FIRST.org ↗
6.5%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs94th percentile — riskier than 94% of all scored CVEsHighest risk
1.11%9.68%18.2%26.8%22.0%6.5%May 26Sep 26Nov 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

1 pkg affected
💎nokogiri

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects RubyGems packages — download data is not available via public APIs for these ecosystems.

Description

parser.c in libxml2 before 2.9.5 does not prevent infinite recursion in parameter entities.

Affected Packages

1 total 1 fixed
EcosystemPackageVulnerable rangeFix
💎RubyGemsnokogiriall versions1.8.1bundle update nokogiri --conservative

Affected Products

1 product · 1 configurations
Application
libxml2xmlsoft
≤ 2.9.4
range

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for nokogiri, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update nokogiri to 1.8.1 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2017-16932 is resolved across your whole dependency graph.

  3. Workarounds

    If you can't upgrade right away: gate or disable the affected feature, validate untrusted input at the boundary, and avoid passing attacker-controlled data into the vulnerable path. O3's runtime protection blocks exploitation in production as an interim safeguard until the upgrade lands.

Frequently Asked Questions

parser.c in libxml2 before 2.9.5 does not prevent infinite recursion in parameter entities.
O3 Security · Impact-Aware SCA

Is CVE-2017-16932 in your dependencies?

Find it across RubyGems, including transitive dependencies.

CVE-2017-16932: nokogiri — Fixed in 1.8.1