NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
🐘
🐘 Packagist
Not in CISA KEV
MEDIUM severity

CVE-2017-16807 — cms

MEDIUM

CVE-2017-16807 is a medium-severity (CVSS 5.4) Cross-site Scripting (XSS) vulnerability in getkirby/cms. 3 public exploit or proof-of-concept references are indexed, so weaponization risk is real. A fix is available for getkirby/cms — see the affected versions and patch details below.

Kirby XSS Vulnerability

Also known asGHSA-275c-v3rc-xghx
Published
Updated
Affected
3 pkgs
Patched
3 / 3
Exploits
3 known
Exploitation data as of Nov 5, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

EPSS Exploitation Probability

via FIRST.org ↗
2.4%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs84th percentile — riskier than 84% of all scored CVEsHighest risk
0.00%1.04%2.07%3.11%0.1%2.4%Jun 26Sep 26Nov 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

3 pkgs affected
🐘getkirby/cms🐘getkirby/cms🐘getkirby/cms

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects Packagist packages — download data is not available via public APIs for these ecosystems.

Description

A cross-site Scripting (XSS) vulnerability in Kirby Panel before 2.3.3, 2.4.x before 2.4.2, and 2.5.x before 2.5.7 exists when displaying a specially prepared SVG document that has been uploaded as a content file.

Affected Packages

3 total 3 fixed
EcosystemPackageVulnerable rangeFix
🐘Packagistgetkirby/cmsall versions2.3.3composer require getkirby/cms:^2.3.3
🐘Packagistgetkirby/cms≥ 2.4&&< 2.4.22.4.2composer require getkirby/cms:^2.4.2
🐘Packagistgetkirby/cms≥ 2.5&&< 2.5.72.5.7composer require getkirby/cms:^2.5.7

Affected Products

1 product · 3 configurations
Application
panelgetkirby
≥ 2.5.0 && < 2.5.7
range
Exploits & PoCs
3

Research use only. For defensive security, authorized penetration testing, and academic research only. Never execute exploit code against systems without explicit written authorization.

EDB-43140webappsphp✓ Verified

Kirby CMS < 2.5.7 - Cross-Site Scripting

by Ishaq Mohammed · Nov 13, 2017

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for getkirby/cms, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update getkirby/cms to 2.3.3 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2017-16807 is resolved across your whole dependency graph.

  3. Workarounds

    Escape or sanitise the affected output on the server side rather than relying on client-side filtering, and add a Content-Security-Policy that blocks inline script execution so injected markup cannot run even if it reaches the page.

Frequently Asked Questions

A cross-site Scripting (XSS) vulnerability in Kirby Panel before 2.3.3, 2.4.x before 2.4.2, and 2.5.x before 2.5.7 exists when displaying a specially prepared SVG document that has been uploaded as a content file.
O3 Security · Impact-Aware SCA

Is CVE-2017-16807 in your dependencies?

Find it across Packagist, including transitive dependencies.

CVE-2017-16807: cms XSS — Fixed in 2.3.3