NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
🐍
🐍 PyPI
Not in CISA KEV
CRITICAL severity

CVE-2017-16616 — pyanyapi

CRITICALFix: Stranger6667/pyanyapi@810db62

CVE-2017-16616 is a critical-severity (CVSS 9.8) vulnerability in pyanyapi. A fix is available for pyanyapi — see the affected versions and patch details below.

Unsafe pyyaml load usage in PyAnyAPI

Also known asGHSA-vg8g-jpm9-jh8rPYSEC-2017-23
Published
Updated
Affected
1 pkg
Patched
1 / 1
Exploits
None indexed
Exploitation data as of Oct 29, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

EPSS Exploitation Probability

via FIRST.org ↗
3.6%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs89th percentile — riskier than 89% of all scored CVEsHighest risk
0.46%1.76%3.05%4.35%1.2%3.6%Apr 26Aug 26Oct 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

1 pkg affected
🐍pyanyapi

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects PyPI packages — download data is not available via public APIs for these ecosystems.

Description

An exploitable vulnerability exists in the YAML parsing functionality in the YAMLParser method in Interfaces.py in PyAnyAPI before 0.6.1. A YAML parser can execute arbitrary Python commands resulting in command execution because load is used where safe_load should have been used. An attacker can insert Python into loaded YAML to trigger this vulnerability.

Affected Packages

1 total 1 fixed
EcosystemPackageVulnerable rangeFix
🐍PyPIpyanyapiall versions0.6.1pip install --upgrade 'pyanyapi==0.6.1'

Affected Products

1 product · 1 configurations
Application
pyanyapipyanyapi_project
< 0.6.1
range

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for pyanyapi, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update pyanyapi to 0.6.1 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2017-16616 is resolved across your whole dependency graph.

  3. Workarounds

    If you can't upgrade right away: gate or disable the affected feature, validate untrusted input at the boundary, and avoid passing attacker-controlled data into the vulnerable path. O3's runtime protection blocks exploitation in production as an interim safeguard until the upgrade lands.

Frequently Asked Questions

An exploitable vulnerability exists in the YAML parsing functionality in the YAMLParser method in Interfaces.py in PyAnyAPI before 0.6.1. A YAML parser can execute arbitrary Python commands resulting in command execution because load is used where safe_load should have been used. An attacker can insert Python into loaded YAML to trigger this vulnerability.
O3 Security · Impact-Aware SCA

Is CVE-2017-16616 in your dependencies?

Find it across PyPI, including transitive dependencies.

CVE-2017-16616: pyanyapi — Fixed in 0.6.1