CVE-2017-16137 is a medium-severity (CVSS 5.3) Uncontrolled Resource Consumption vulnerability in debug. A fix is available for debug — see the affected versions and patch details below.
Regular Expression Denial of Service in debug
Exploitation Status
No confirmed exploitation observed yet
- CISA’s own triage has not observed active exploitation or public proof-of-concept code for this CVE as of its last assessment.
Exploitation and automatability from CISA’s SSVC triage for CVE-2017-16137.
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
How urgent is this, really
Where this sits among everything scored
Real-World Exposure
How broadly this vulnerability is actually deployed: weekly install volume shows current usage, and reverse-dependency count shows how many other packages break if it stays unpatched.
debugnpmDescription
Affected versions of debug are vulnerable to regular expression denial of service when untrusted user input is passed into the o formatter.
As it takes 50,000 characters to block the event loop for 2 seconds, this issue is a low severity issue.
This was later re-introduced in version v3.2.0, and then repatched in versions 3.2.7 and 4.3.1.
Recommendation
Version 2.x.x: Update to version 2.6.9 or later. Version 3.1.x: Update to version 3.1.0 or later. Version 3.2.x: Update to version 3.2.7 or later. Version 4.x.x: Update to version 4.3.1 or later.
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| 📦npm | debug | all versions | 2.6.9npm install debug@2.6.9 |
| 📦npm | debug | ≥ 3.0.0&&< 3.1.0 | 3.1.0npm install debug@3.1.0 |
| 📦npm | debug | ≥ 3.2.0&&< 3.2.7 | 3.2.7npm install debug@3.2.7 |
| 📦npm | debug | ≥ 4.0.0&&< 4.3.1 | 4.3.1npm install debug@4.3.1 |
Affected Products
debugdebug_projectDetection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for debug, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update debug to 2.6.9 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2017-16137 is resolved across your whole dependency graph.
Workarounds
Cap what an attacker can consume: apply request size, rate and timeout limits in front of the affected component, and run it with memory and CPU limits so exhaustion degrades one worker rather than the whole service.
Fixing This On Your OS
If you run this on a Linux distribution, patch through your package manager against the distro's own security advisory below — it tracks the exact backported fix for your release, which can ship on a different timeline (and sometimes a different severity) than the upstream project.
This issue affects the versions of rh-nodejs4-nodejs-debug, rh-nodejs6-nodejs-debug, and rh-nodejs8-nodejs-debug as shipped with Red Hat Software Collections 3. Red Hat Product Security has rated this issue as having Moderate security impact. A future update may address this issue. For additional information, refer to…
| Product | Fixed in | Advisory |
|---|---|---|
| Red Hat Quay 3 | quay/quay-rhel8:v3.6.0-62 | RHSA-2021:3917 |
Frequently Asked Questions
Is CVE-2017-16137 in your dependencies?
Find it across npm, including transitive dependencies.