Your RSA-2048 keys break in 2030. Find every one of them before attackers do.
📦
📦 npm
Not in CISA KEV
HIGH severity

CVE-2017-16111 — content

HIGH

CVE-2017-16111 is a high-severity (CVSS 7.5) Uncontrolled Resource Consumption vulnerability in content. A fix is available for content — see the affected versions and patch details below.

Regular Expression Denial of Service in content

Also known asGHSA-x6wp-rfwh-hcx7
Published
Updated
Affected
1 pkg
Patched
1 / 1
Exploits
None indexed
Exploitation data as of Oct 30, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

EPSS Exploitation Probability

via FIRST.org ↗
1.1%probability of exploitation in next 30 days
Lower Risk-0.02%
Lower risk than most CVEs66th percentile — riskier than 66% of all scored CVEsHighest risk
0.00%0.54%1.08%1.63%0.3%1.1%Apr 26Aug 26Oct 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

CVE-2017-16111 by exploitation likelihood (EPSS) against impact (CVSS). Outside the shaded patch-first corner.

Where this sits among everything scored

Of 397,508 CVEs with a current EPSS score, this one falls in the < 10% band (highlighted). Counts from FIRST.org, log-scaled.

Real-World Exposure

1 pkg affected

How broadly this vulnerability is actually deployed: weekly install volume shows current usage, a proxy for how much of the ecosystem is exposed.

contentnpm
86Kdownloads / week

Description

The content module is a module to parse HTTP Content-* headers. It is used by the hapijs framework to provide this functionality. The module is vulnerable to regular expression denial of service when passed a specifically crafted Content-Type or Content-Disposition header.

Affected Packages

1 total 1 fixed
EcosystemPackageVulnerable rangeFix
📦npmcontentall versions3.0.7npm install content@3.0.7

Affected Products

1 product · 1 configurations
Application
contentcontent_project
≤ 3.0.5
range

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for content, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update content to 3.0.7 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2017-16111 is resolved across your whole dependency graph.

  3. Workarounds

    Cap what an attacker can consume: apply request size, rate and timeout limits in front of the affected component, and run it with memory and CPU limits so exhaustion degrades one worker rather than the whole service.

Frequently Asked Questions

The content module is a module to parse HTTP Content-* headers. It is used by the hapijs framework to provide this functionality. The module is vulnerable to regular expression denial of service when passed a specifically crafted Content-Type or Content-Disposition header.
O3 Security · Impact-Aware SCA

Is CVE-2017-16111 in your dependencies?

Find it across npm, including transitive dependencies.

CVE-2017-16111: content DoS — Fixed in 3.0.7