CVE-2017-15806 — mail
HIGHCVE-2017-15806 is a high-severity (CVSS 8.1) Code Injection vulnerability in zetacomponents/mail. 1 public exploit or proof-of-concept reference is indexed, so weaponization risk is real. A fix is available for zetacomponents/mail — see the affected versions and patch details below.
Zeta Components Mail Arbitrary code execution via a crafted email address
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
How urgent is this, really
Where this sits among everything scored
Real-World Exposure
zetacomponents/mailReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects Packagist packages — download data is not available via public APIs for these ecosystems.
Description
The send function in the ezcMailMtaTransport class in Zeta Components Mail before 1.8.2 does not properly restrict the set of characters used in the ezcMail returnPath property, which might allow remote attackers to execute arbitrary code via a crafted email address, as demonstrated by one containing "-X/path/to/wwwroot/file.php."
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| 🐘Packagist | zetacomponents/mail | all versions | 1.8.2composer require zetacomponents/mail:^1.8.2 |
Affected Products
mailzetacomponentsResearch use only. For defensive security, authorized penetration testing, and academic research only. Never execute exploit code against systems without explicit written authorization.
Zeta Components Mail 1.8.1 - Remote Code Execution
by MalwareBenchmark · Nov 16, 2017
Detection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for zetacomponents/mail, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update zetacomponents/mail to 1.8.2 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2017-15806 is resolved across your whole dependency graph.
Workarounds
Stop passing untrusted input into the interpreter or shell: call the affected binary with an argument array rather than a composed command string, reject anything outside a strict allowlist of expected values, and run the component under an account that cannot reach beyond the work it legitimately does.
Frequently Asked Questions
Is CVE-2017-15806 in your dependencies?
Find it across Packagist, including transitive dependencies.