NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
☕
☕ Maven
Not in CISA KEV
MEDIUM severity

CVE-2017-15691 — uimafit-core

MEDIUM

CVE-2017-15691 is a medium-severity (CVSS 6.5) XML External Entity (XXE) vulnerability in org.apache.uima:uimafit-core. A fix is available for org.apache.uima:uimafit-core — see the affected versions and patch details below.

Improper Restriction of XML External Entity Reference in Apache uimaj

Also known asGHSA-wp2f-hrg2-3r5m
Published
Updated
Affected
4 pkgs
Patched
4 / 4
Exploits
None indexed
Exploitation data as of Nov 3, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

EPSS Exploitation Probability

via FIRST.org ↗
8.9%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs95th percentile — riskier than 95% of all scored CVEsHighest risk
0.00%3.83%7.66%11.5%0.8%8.9%May 26Sep 26Nov 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

4 pkgs affected
☕org.apache.uima:uimafit-core☕org.apache.uima:uimaj-core☕org.apache.uima:uimaj-core☕org.apache.uima:uimaj-as-core

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects Maven packages — download data is not available via public APIs for these ecosystems.

Description

In Apache uimaj prior to 2.10.2, Apache uimaj 3.0.0-xxx prior to 3.0.0-beta, Apache uima-as prior to 2.10.2, Apache uimaFIT prior to 2.4.0, Apache uimaDUCC prior to 2.2.2, this vulnerability relates to an XML external entity expansion (XXE) capability of various XML parsers. UIMA as part of its configuration and operation may read XML from various sources, which could be tainted in ways to cause inadvertent disclosure of local files or other internal content.

Affected Packages

4 total 4 fixed
EcosystemPackageVulnerable rangeFix
☕Mavenorg.apache.uima:uimafit-coreall versions2.4.0org.apache.uima:uimafit-core:2.4.0
☕Mavenorg.apache.uima:uimaj-coreall versions2.10.2org.apache.uima:uimaj-core:2.10.2
☕Mavenorg.apache.uima:uimaj-core≥ 3.0.0-alpha&&< 3.0.0-beta3.0.0-betaorg.apache.uima:uimaj-core:3.0.0-beta
☕Mavenorg.apache.uima:uimaj-as-coreall versions2.10.2org.apache.uima:uimaj-as-core:2.10.2

Affected Products

4 products · 7 configurations
Application
uima-asapache
< 2.10.2
range
Application
uimaduccapache
< 2.2.2
range
Application
uimafitapache
< 2.4.0
range
Application
uimajapache
< 2.10.2
1 version
3.0.0

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for org.apache.uima:uimafit-core, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update org.apache.uima:uimafit-core to 2.4.0 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2017-15691 is resolved across your whole dependency graph.

  3. Workarounds

    If you can't upgrade right away: gate or disable the affected feature, validate untrusted input at the boundary, and avoid passing attacker-controlled data into the vulnerable path. O3's runtime protection blocks exploitation in production as an interim safeguard until the upgrade lands.

Fixing This On Your OS

If you run this on a Linux distribution, patch through your package manager against the distro's own security advisory below — it tracks the exact backported fix for your release, which can ship on a different timeline (and sometimes a different severity) than the upstream project.

Red HatImportant

This issue affects the versions of lucene (which contains an embedded copy of uima) as shipped with Red Hat Satellite 6.0 and 6.1. Red Hat Satellite 6.2 and later do not include lucene and are not vulnerable to this issue.

ProductFixed inAdvisory
Red Hat Fuse 7.3.1uimajRHSA-2019:1545

Frequently Asked Questions

In Apache uimaj prior to 2.10.2, Apache uimaj 3.0.0-xxx prior to 3.0.0-beta, Apache uima-as prior to 2.10.2, Apache uimaFIT prior to 2.4.0, Apache uimaDUCC prior to 2.2.2, this vulnerability relates to an XML external entity expansion (XXE) capability of various XML parsers. UIMA as part of its configuration and operation may read XML from various sources, which could be tainted in ways to cause inadvertent disclosure of local files or other internal content.
O3 Security · Impact-Aware SCA

Is CVE-2017-15691 in your dependencies?

Find it across Maven, including transitive dependencies.

CVE-2017-15691: uimafit-core XXE — Fixed in 2.4.0