CVE-2017-15682 — crafter-core
MEDIUMCVE-2017-15682 is a medium-severity (CVSS 6.1) Cross-site Scripting (XSS) vulnerability in org.craftercms:crafter-core. A fix is available for org.craftercms:crafter-core — see the affected versions and patch details below.
Cross site scripting in Crafter CMS
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
How urgent is this, really
Where this sits among everything scored
Real-World Exposure
org.craftercms:crafter-coreReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects Maven packages — download data is not available via public APIs for these ecosystems.
Description
In Crafter CMS Crafter Studio 3.0.1 an unauthenticated attacker is able to inject malicious JavaScript code resulting in a stored/blind XSS in the admin panel.
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| ☕Maven | org.craftercms:crafter-core | ≥ 3.0.0&&< 3.0.1 | 3.0.1org.craftercms:crafter-core:3.0.1 |
Affected Products
crafter cmscraftercmsDetection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for org.craftercms:crafter-core, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update org.craftercms:crafter-core to 3.0.1 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2017-15682 is resolved across your whole dependency graph.
Workarounds
Escape or sanitise the affected output on the server side rather than relying on client-side filtering, and add a Content-Security-Policy that blocks inline script execution so injected markup cannot run even if it reaches the page.
Frequently Asked Questions
Is CVE-2017-15682 in your dependencies?
Find it across Maven, including transitive dependencies.