NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
💎
💎 RubyGems
Not in CISA KEV
HIGH severity

CVE-2017-15412 — nokogiri

HIGH

CVE-2017-15412 is a high-severity (CVSS 8.8) Use After Free vulnerability in nokogiri. 2 public exploit or proof-of-concept references are indexed, so weaponization risk is real. A fix is available for nokogiri — see the affected versions and patch details below.

Nokogiri gem, via libxml, is affected by DoS vulnerabilities

Also known asGHSA-r58r-74gx-6wx3
Published
Updated
Affected
1 pkg
Patched
1 / 1
Exploits
2 known
Exploitation data as of Nov 2, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

EPSS Exploitation Probability

via FIRST.org ↗
2.9%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs87th percentile — riskier than 87% of all scored CVEsHighest risk
1.70%2.28%2.87%3.46%2.2%2.9%May 26Sep 26Nov 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

1 pkg affected
💎nokogiri

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects RubyGems packages — download data is not available via public APIs for these ecosystems.

Description

Use after free in libxml2 before 2.9.5, as used in Google Chrome prior to 63.0.3239.84 and other products, allowed a remote attacker to potentially exploit heap corruption via a crafted HTML page.

Affected Packages

1 total 1 fixed
EcosystemPackageVulnerable rangeFix
💎RubyGemsnokogiriall versions1.8.2bundle update nokogiri --conservative

Affected Products

6 products · 8 configurations
OS
debian linuxdebian
3 versions
7.08.09.0
Application
chromegoogle
< 63.0.3239.84
range
OS
enterprise linux desktopredhat
1 version
6.0
OS
enterprise linux serverredhat
1 version
6.0
OS
enterprise linux workstationredhat
1 version
6.0
Application
libxml2xmlsoft
< 2.9.5
range
Exploits & PoCs
2

Research use only. For defensive security, authorized penetration testing, and academic research only. Never execute exploit code against systems without explicit written authorization.

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for nokogiri, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update nokogiri to 1.8.2 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2017-15412 is resolved across your whole dependency graph.

  3. Workarounds

    Stop feeding it untrusted input: reject or quarantine files and payloads from unverified sources until you can upgrade, restrict accepted formats to the ones you actually need, and run the parsing or decoding step in a least-privileged sandbox or short-lived worker so a crash or corrupted read cannot reach the rest of the process.

Fixing This On Your OS

If you run this on a Linux distribution, patch through your package manager against the distro's own security advisory below — it tracks the exact backported fix for your release, which can ship on a different timeline (and sometimes a different severity) than the upstream project.

Red HatImportant
ProductFixed inAdvisory
Red Hat Ansible Tower 3.5 for RHEL 7ansible-tower-35/ansible-tower:3.5.6-1RHBA-2020:1539
Red Hat Ansible Tower 3.6 for RHEL 7ansible-tower-36/ansible-tower:3.6.4-1RHBA-2020:1540
Red Hat Enterprise Linux 6 Supplementarychromium-browser-0:63.0.3239.84-1.el6_9RHSA-2017:3401
Red Hat Enterprise Linux 7libxml2-0:2.9.1-6.el7.4RHSA-2020:1190
Red Hat JBoss Core Serviceslibxml2RHSA-2018:0287

Frequently Asked Questions

Use after free in libxml2 before 2.9.5, as used in Google Chrome prior to 63.0.3239.84 and other products, allowed a remote attacker to potentially exploit heap corruption via a crafted HTML page.
O3 Security · Impact-Aware SCA

Is CVE-2017-15412 in your dependencies?

Find it across RubyGems, including transitive dependencies.

CVE-2017-15412: nokogiri — Fixed in 1.8.2