NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
🐘
🐘 Packagist
Not in CISA KEV
CRITICAL severity

CVE-2017-15367 — bacula-web

CRITICALFix: bacula-web/bacula-web@90d4c44

CVE-2017-15367 is a critical-severity (CVSS 9.8) SQL Injection vulnerability in bacula-web/bacula-web. 2 public exploit or proof-of-concept references are indexed, so weaponization risk is real. A fix is available for bacula-web/bacula-web — see the affected versions and patch details below.

Bacula-web SQL Injection Vulnerabilities

Also known asGHSA-fv4m-5j2c-787r
Published
Updated
Affected
1 pkg
Patched
1 / 1
Exploits
2 known
Exploitation data as of Nov 3, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

EPSS Exploitation Probability

via FIRST.org ↗
23.1%probability of exploitation in next 30 days
Moderate Risk0.00%
Lower risk than most CVEs98th percentile — riskier than 98% of all scored CVEsHighest risk
21.6%22.7%23.8%24.9%22.2%23.1%May 26Sep 26Nov 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

1 pkg affected
🐘bacula-web/bacula-web

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects Packagist packages — download data is not available via public APIs for these ecosystems.

Description

Bacula-web before 8.0.0-rc2 is affected by multiple SQL Injection vulnerabilities that could allow an attacker to access the Bacula database and, depending on configuration, escalate privileges on the server.

Affected Packages

1 total 1 fixed
EcosystemPackageVulnerable rangeFix
🐘Packagistbacula-web/bacula-weball versions8.0.0-rc2composer require bacula-web/bacula-web:^8.0.0-rc2

Affected Products

1 product · 2 configurations
Application
bacula-webbacula
≤ 7.4.0
1 version
8.0.0
Exploits & PoCs
2

Research use only. For defensive security, authorized penetration testing, and academic research only. Never execute exploit code against systems without explicit written authorization.

EDB-44272webappsphp

Bacula-Web < 8.0.0-rc2 - SQL Injection

by Gustavo Sorondo · Mar 9, 2018

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for bacula-web/bacula-web, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update bacula-web/bacula-web to 8.0.0-rc2 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2017-15367 is resolved across your whole dependency graph.

  3. Workarounds

    Until you can upgrade, make sure every query built from user input uses parameterised statements or a prepared-statement API rather than string concatenation, and reduce the database account's privileges so an injected query cannot read or alter data beyond what the feature needs.

Frequently Asked Questions

Bacula-web before 8.0.0-rc2 is affected by multiple SQL Injection vulnerabilities that could allow an attacker to access the Bacula database and, depending on configuration, escalate privileges on the server.
O3 Security · Impact-Aware SCA

Is CVE-2017-15367 in your dependencies?

Find it across Packagist, including transitive dependencies.

CVE-2017-15367: bacula-web — Fixed in 8.0.0-rc2