NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
🐘
🐘 Packagist
Not in CISA KEV
MEDIUM severity

CVE-2017-15278 — teampass

MEDIUMFix: nilsteampassnet/TeamPass@f5a7653

CVE-2017-15278 is a medium-severity (CVSS 5.4) Cross-site Scripting (XSS) vulnerability in nilsteampassnet/teampass. A fix is available for nilsteampassnet/teampass — see the affected versions and patch details below.

TeamPass Cross-Site Scripting (XSS)

Also known asGHSA-28pv-2j2h-fmhc
Published
Updated
Affected
1 pkg
Patched
1 / 1
Exploits
None indexed
Exploitation data as of Nov 3, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

EPSS Exploitation Probability

via FIRST.org ↗
0.9%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs61th percentile — riskier than 61% of all scored CVEsHighest risk
0.00%0.48%0.97%1.45%0.3%0.9%May 26Sep 26Nov 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

1 pkg affected
🐘nilsteampassnet/teampass

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects Packagist packages — download data is not available via public APIs for these ecosystems.

Description

Cross-Site Scripting (XSS) was discovered in TeamPass before 2.1.27.9. The vulnerability exists due to insufficient filtration of data (in /sources/folders.queries.php). An attacker could execute arbitrary HTML and script code in a browser in the context of the vulnerable website.

Affected Packages

1 total 1 fixed
EcosystemPackageVulnerable rangeFix
🐘Packagistnilsteampassnet/teampassall versions2.1.27.9composer require nilsteampassnet/teampass:^2.1.27.9

Affected Products

1 product · 1 configurations
Application
teampassteampass
≤ 2.1.27.8
range

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for nilsteampassnet/teampass, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update nilsteampassnet/teampass to 2.1.27.9 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2017-15278 is resolved across your whole dependency graph.

  3. Workarounds

    Escape or sanitise the affected output on the server side rather than relying on client-side filtering, and add a Content-Security-Policy that blocks inline script execution so injected markup cannot run even if it reaches the page.

Frequently Asked Questions

Cross-Site Scripting (XSS) was discovered in TeamPass before 2.1.27.9. The vulnerability exists due to insufficient filtration of data (in /sources/folders.queries.php). An attacker could execute arbitrary HTML and script code in a browser in the context of the vulnerable website.
O3 Security · Impact-Aware SCA

Is CVE-2017-15278 in your dependencies?

Find it across Packagist, including transitive dependencies.

CVE-2017-15278: teampass XSS — Fixed in 2.1.27.9