NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
🐍
🐍 PyPI
Not in CISA KEV
HIGH severity

CVE-2017-15112 — keycloak-httpd-client-ins…

HIGHFix: jdennis/keycloak-httpd-client-install@c3121b2

CVE-2017-15112 is a high-severity (CVSS 7.8) Information Exposure vulnerability in keycloak-httpd-client-install. A fix is available for keycloak-httpd-client-install — see the affected versions and patch details below.

keycloak-httpd-client-install Insecure Secrets

Also known asGHSA-89c9-3758-737wPYSEC-2026-828
Published
Updated
Affected
1 pkg
Patched
1 / 1
Exploits
None indexed
Exploitation data as of Oct 27, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

EPSS Exploitation Probability

via FIRST.org ↗
0.4%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs32th percentile — riskier than 32% of all scored CVEsHighest risk
0.00%0.29%0.59%0.88%0.1%0.4%Apr 26Aug 26Oct 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

1 pkg affected
🐍keycloak-httpd-client-install

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects PyPI packages — download data is not available via public APIs for these ecosystems.

Description

keycloak-httpd-client-install versions before 0.8 allow users to insecurely pass password through command line, leaking it via command history and process info to other local users.

Affected Packages

1 total 1 fixed
EcosystemPackageVulnerable rangeFix
🐍PyPIkeycloak-httpd-client-installall versions0.8pip install --upgrade 'keycloak-httpd-client-install==0.8'

Affected Products

1 product · 1 configurations
Application
keycloak-httpd-client-installkeycloak-httpd-client-install_project
< 0.8
range

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for keycloak-httpd-client-install, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update keycloak-httpd-client-install to 0.8 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2017-15112 is resolved across your whole dependency graph.

  3. Workarounds

    Assume what was exposed is already known: rotate any credential, token or key that the affected component could return, restrict the endpoint to callers that genuinely need it, and strip sensitive fields from responses and error output at the boundary rather than relying on the client not to read them.

Fixing This On Your OS

If you run this on a Linux distribution, patch through your package manager against the distro's own security advisory below — it tracks the exact backported fix for your release, which can ship on a different timeline (and sometimes a different severity) than the upstream project.

Red HatLow

Red Hat Product Security has rated this issue as having security impact of Low. This issue may be fixed in a future version of Red Hat Enterprise Linux. OpenStack users please note, this issue is present in: * Red Hat OpenStack Platform 9.0 (Mitaka) * Red Hat OpenStack Platform 10.0 (Newton) * Red Hat OpenStack…

ProductFixed inAdvisory
Red Hat Enterprise Linux 7keycloak-httpd-client-install-0:0.8-1.el7RHSA-2019:2137

Frequently Asked Questions

keycloak-httpd-client-install versions before 0.8 allow users to insecurely pass password through command line, leaking it via command history and process info to other local users.
O3 Security · Impact-Aware SCA

Is CVE-2017-15112 in your dependencies?

Find it across PyPI, including transitive dependencies.

CVE-2017-15112: keycloak-httpd-client-ins… — Fixed in 0.8