NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
🐘
🐘 Packagist
Not in CISA KEV
MEDIUM severity

CVE-2017-14775 — framework

MEDIUMFix: laravel/framework#21320

CVE-2017-14775 is a medium-severity (CVSS 5.9) Information Exposure vulnerability in laravel/framework. A fix is available for laravel/framework — see the affected versions and patch details below.

Laravel Sensitive Data Exposure

Also known asGHSA-c2v7-j5gq-wcq4
Published
Updated
Affected
2 pkgs
Patched
2 / 2
Exploits
None indexed
Exploitation data as of Nov 6, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

EPSS Exploitation Probability

via FIRST.org ↗
1.2%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs68th percentile — riskier than 68% of all scored CVEsHighest risk
0.00%0.56%1.13%1.69%0.3%1.2%May 26Sep 26Nov 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

2 pkgs affected
🐘laravel/framework🐘illuminate/auth

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects Packagist packages — download data is not available via public APIs for these ecosystems.

Description

Laravel before 5.5.10 mishandles the remember_me token verification process because DatabaseUserProvider does not have constant-time token comparison.

Affected Packages

2 total 2 fixed
EcosystemPackageVulnerable rangeFix
🐘Packagistlaravel/frameworkall versions5.5.10composer require laravel/framework:^5.5.10
🐘Packagistilluminate/authall versions5.5.10composer require illuminate/auth:^5.5.10

Affected Products

1 product · 1 configurations
Application
laravellaravel
≤ 5.5.9
range

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for laravel/framework, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update laravel/framework to 5.5.10 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2017-14775 is resolved across your whole dependency graph.

  3. Workarounds

    Assume what was exposed is already known: rotate any credential, token or key that the affected component could return, restrict the endpoint to callers that genuinely need it, and strip sensitive fields from responses and error output at the boundary rather than relying on the client not to read them.

Frequently Asked Questions

Laravel before 5.5.10 mishandles the remember_me token verification process because DatabaseUserProvider does not have constant-time token comparison.
O3 Security · Impact-Aware SCA

Is CVE-2017-14775 in your dependencies?

Find it across Packagist, including transitive dependencies.

CVE-2017-14775: framework — Fixed in 5.5.10