CVE-2017-12440 is a high-severity (CVSS 7.5) Missing Authentication vulnerability in aodh. A fix is available for aodh — see the affected versions and patch details below.
Openstack Aodh can be used to launder Keystone trusts
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
How urgent is this, really
Where this sits among everything scored
Real-World Exposure
aodhReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects PyPI packages — download data is not available via public APIs for these ecosystems.
Description
Aodh as packaged in Openstack Ocata and Newton before change-ID I8fd11a7f9fe3c0ea5f9843a89686ac06713b7851 and before Pike-rc1 does not verify that trust IDs belong to the user when creating alarm action with the scheme trust+http, which allows remote authenticated users with knowledge of trust IDs where Aodh is the trustee to obtain a Keystone token and perform unspecified authenticated actions by adding an alarm action with the scheme trust+http, and providing a trust id where Aodh is the trustee.
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| 🐍PyPI | aodh | all versions | 6.0.1pip install --upgrade 'aodh==6.0.1' |
Affected Products
openstackopenstackDetection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for aodh, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update aodh to 6.0.1 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2017-12440 is resolved across your whole dependency graph.
Workarounds
Put an independent control in front of the weakness: restrict the affected endpoint or interface to trusted networks, require an additional authentication factor or proxy-level check, and invalidate existing sessions and credentials in case the flaw has already been used.
Fixing This On Your OS
If you run this on a Linux distribution, patch through your package manager against the distro's own security advisory below — it tracks the exact backported fix for your release, which can ship on a different timeline (and sometimes a different severity) than the upstream project.
| Product | Fixed in | Advisory |
|---|---|---|
| Red Hat OpenStack Platform 10.0 (Newton) | openstack-aodh-0:3.0.4-1.el7ost | RHSA-2017:3227 |
| Red Hat OpenStack Platform 11.0 (Ocata) | openstack-aodh-0:4.0.2-3.el7ost | RHSA-2018:0315 |
Frequently Asked Questions
Is CVE-2017-12440 in your dependencies?
Find it across PyPI, including transitive dependencies.