NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
☕
☕ Maven
Not in CISA KEV
MEDIUM severity

CVE-2017-12197 — libpam4j

MEDIUMFix: kohsuke/libpam4j@02ffdff

CVE-2017-12197 is a medium-severity (CVSS 6.5) CWE-863 vulnerability in org.kohsuke:libpam4j. A fix is available for org.kohsuke:libpam4j — see the affected versions and patch details below.

Improper Input Validation in libpam4j

Also known asGHSA-x9rg-q5fx-fx66
Published
Updated
Affected
1 pkg
Patched
1 / 1
Exploits
None indexed
Exploitation data as of Oct 27, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

EPSS Exploitation Probability

via FIRST.org ↗
1.5%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs74th percentile — riskier than 74% of all scored CVEsHighest risk
0.01%0.67%1.34%2.01%0.5%1.5%Apr 26Aug 26Oct 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

1 pkg affected
☕org.kohsuke:libpam4j

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects Maven packages — download data is not available via public APIs for these ecosystems.

Description

It was found that libpam4j up to and including 1.8 did not properly validate user accounts when authenticating. A user with a valid password for a disabled account would be able to bypass security restrictions and possibly access sensitive information.

Affected Packages

1 total 1 fixed
EcosystemPackageVulnerable rangeFix
☕Mavenorg.kohsuke:libpam4jall versions1.10org.kohsuke:libpam4j:1.10

Affected Products

3 products · 5 configurations
OS
debian linuxdebian
3 versions
7.08.09.0
Application
libpam4jlibpam4j_project
≤ 1.8
range
OS
enterprise linuxredhat
1 version
6.0

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for org.kohsuke:libpam4j, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update org.kohsuke:libpam4j to 1.10 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2017-12197 is resolved across your whole dependency graph.

  3. Workarounds

    Put an independent control in front of the weakness: restrict the affected endpoint or interface to trusted networks, require an additional authentication factor or proxy-level check, and invalidate existing sessions and credentials in case the flaw has already been used.

Fixing This On Your OS

If you run this on a Linux distribution, patch through your package manager against the distro's own security advisory below — it tracks the exact backported fix for your release, which can ship on a different timeline (and sometimes a different severity) than the upstream project.

Red HatModerate
ProductFixed inAdvisory
Red Hat Single Sign-On 7.1see advisoryRHSA-2017:2906
Red Hat Single Sign-On 7.1 for RHEL 6rh-sso7-keycloak-0:2.5.14-1.Final_redhat_1.1.jbcs.el6RHSA-2017:2904
Red Hat Single Sign-On 7.1 for RHEL 7rh-sso7-keycloak-0:2.5.14-1.Final_redhat_1.1.jbcs.el7RHSA-2017:2905

Frequently Asked Questions

It was found that libpam4j up to and including 1.8 did not properly validate user accounts when authenticating. A user with a valid password for a disabled account would be able to bypass security restrictions and possibly access sensitive information.
O3 Security · Impact-Aware SCA

Is CVE-2017-12197 in your dependencies?

Find it across Maven, including transitive dependencies.

CVE-2017-12197: libpam4j — Fixed in 1.10