CVE-2017-12165 is a high-severity (CVSS 7.5) CWE-444 vulnerability in io.undertow:undertow-core. A fix is available for io.undertow:undertow-core — see the affected versions and patch details below.
Undertow Request Smuggling vulnerability
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
How urgent is this, really
Where this sits among everything scored
Real-World Exposure
io.undertow:undertow-core☕io.undertow:undertow-core☕io.undertow:undertow-coreReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects Maven packages — download data is not available via public APIs for these ecosystems.
Description
It was discovered that Undertow before 1.4.17, 1.3.31 and 2.0.0 processes http request headers with unusual whitespaces which can cause possible http request smuggling.
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| ☕Maven | io.undertow:undertow-core | all versions | 1.3.31io.undertow:undertow-core:1.3.31 |
| ☕Maven | io.undertow:undertow-core | ≥ 1.4.0&&< 1.4.17 | 1.4.17io.undertow:undertow-core:1.4.17 |
| ☕Maven | io.undertow:undertow-core | ≥ 2.0.0.Alpha1&&< 2.0.0.Beta1 | 2.0.0.Beta1io.undertow:undertow-core:2.0.0.Beta1 |
Affected Products
jboss enterprise application platformredhatundertowredhatDetection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for io.undertow:undertow-core, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update io.undertow:undertow-core to 1.3.31 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2017-12165 is resolved across your whole dependency graph.
Workarounds
If you can't upgrade right away: gate or disable the affected feature, validate untrusted input at the boundary, and avoid passing attacker-controlled data into the vulnerable path. O3's runtime protection blocks exploitation in production as an interim safeguard until the upgrade lands.
Fixing This On Your OS
If you run this on a Linux distribution, patch through your package manager against the distro's own security advisory below — it tracks the exact backported fix for your release, which can ship on a different timeline (and sometimes a different severity) than the upstream project.
| Product | Fixed in | Advisory |
|---|---|---|
| Red Hat JBoss A-MQ 6.3 | see advisory | RHSA-2018:1322 |
| Red Hat JBoss EAP 7 | see advisory | RHSA-2017:3456 |
| Red Hat JBoss EAP 7 | undertow | RHSA-2018:0003 |
| Red Hat JBoss Enterprise Application Platform 7.0 for RHEL 6 | eap7-activemq-artemis-0:1.1.0-19.SP24_redhat_1.1.ep7.el6 | RHSA-2018:0002 |
| Red Hat JBoss Enterprise Application Platform 7.0 for RHEL 6 | eap7-jboss-ec2-eap-0:7.0.9-2.GA_redhat_2.ep7.el6 | RHSA-2018:0005 |
| Red Hat JBoss Enterprise Application Platform 7.0 for RHEL 7 | eap7-activemq-artemis-0:1.1.0-19.SP24_redhat_1.1.ep7.el7 | RHSA-2018:0004 |
| Red Hat JBoss Enterprise Application Platform 7.1 for RHEL 6 | eap7-activemq-artemis-0:1.5.5.008-1.redhat_1.1.ep7.el6 | RHSA-2017:3454 |
| Red Hat JBoss Enterprise Application Platform 7.1 for RHEL 6 | eap7-jboss-ec2-eap-0:7.1.0-5.GA_redhat_5.ep7.el6 | RHSA-2017:3458 |
Frequently Asked Questions
Is CVE-2017-12165 in your dependencies?
Find it across Maven, including transitive dependencies.