NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
.NET
.NET NuGet
Not in CISA KEV
HIGH severity

CVE-2017-11883 — Microsoft.AspNetCore.Serv…

HIGH

CVE-2017-11883 is a high-severity (CVSS 7.5) vulnerability in Microsoft.AspNetCore.Server.WebListener. A fix is available for Microsoft.AspNetCore.Server.WebListener — see the affected versions and patch details below.

Denial of service in ASP.NET Core

Published
Updated
Affected
5 pkgs
Patched
5 / 5
Exploits
None indexed
Exploitation data as of Nov 5, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

EPSS Exploitation Probability

via FIRST.org ↗
8.5%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs95th percentile — riskier than 95% of all scored CVEsHighest risk
0.76%14.6%28.4%42.2%34.4%8.5%May 26Sep 26Nov 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

5 pkgs affected
.NETMicrosoft.AspNetCore.Server.WebListener.NETMicrosoft.AspNetCore.Server.WebListener.NETMicrosoft.Net.Http.Server.NETMicrosoft.Net.Http.Server.NETMicrosoft.AspNetCore.Server.HttpSys

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects NuGet packages — download data is not available via public APIs for these ecosystems.

Description

.NET Core 1.0, 1.1, and 2.0 allow an unauthenticated attacker to remotely cause a denial of service attack against a .NET Core web application by improperly handling web requests, aka ".NET CORE Denial Of Service Vulnerability".

Affected Packages

5 total 5 fixed
EcosystemPackageVulnerable rangeFix
.NETNuGetMicrosoft.AspNetCore.Server.WebListener≥ 1.0.0&&< 1.0.61.0.6dotnet add package Microsoft.AspNetCore.Server.WebListener --version 1.0.6
.NETNuGetMicrosoft.AspNetCore.Server.WebListener≥ 1.1.0&&< 1.1.41.1.4dotnet add package Microsoft.AspNetCore.Server.WebListener --version 1.1.4
.NETNuGetMicrosoft.Net.Http.Server≥ 1.0.0&&< 1.0.61.0.6dotnet add package Microsoft.Net.Http.Server --version 1.0.6
.NETNuGetMicrosoft.Net.Http.Server≥ 1.1.0&&< 1.1.41.1.4dotnet add package Microsoft.Net.Http.Server --version 1.1.4
.NETNuGetMicrosoft.AspNetCore.Server.HttpSys≥ 2.0.0&&< 2.0.22.0.2dotnet add package Microsoft.AspNetCore.Server.HttpSys --version 2.0.2

Affected Products

1 product · 3 configurations
Application
aspnetcoremicrosoft
3 versions
1.01.12.0

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for Microsoft.AspNetCore.Server.WebListener, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update Microsoft.AspNetCore.Server.WebListener to 1.0.6 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2017-11883 is resolved across your whole dependency graph.

  3. Workarounds

    Cap what an attacker can consume: apply request size, rate and timeout limits in front of the affected component, and run it with memory and CPU limits so exhaustion degrades one worker rather than the whole service.

Frequently Asked Questions

.NET Core 1.0, 1.1, and 2.0 allow an unauthenticated attacker to remotely cause a denial of service attack against a .NET Core web application by improperly handling web requests, aka ".NET CORE Denial Of Service Vulnerability".
O3 Security · Impact-Aware SCA

Is CVE-2017-11883 in your dependencies?

Find it across NuGet, including transitive dependencies.

CVE-2017-11883: Microsoft.AspNetCore — Fixed in 1.0.6