NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
🐘
🐘 Packagist
Not in CISA KEV
CRITICAL severity

CVE-2017-11366 — codiad

CRITICALFix: Codiad/Codiad#1013

CVE-2017-11366 is a critical-severity (CVSS 9.8) OS Command Injection vulnerability in codiad/codiad. 1 public exploit or proof-of-concept reference is indexed, so weaponization risk is real. A fix is available for codiad/codiad — see the affected versions and patch details below.

Codiad Vulnerable to Shell Command Injection

Also known asGHSA-jccv-3h4x-35mv
Published
Updated
Affected
1 pkg
Patched
1 / 1
Exploits
1 known
Exploitation data as of Oct 31, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

EPSS Exploitation Probability

via FIRST.org ↗
7.5%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs95th percentile — riskier than 95% of all scored CVEsHighest risk
0.00%14.1%28.3%42.4%34.3%7.5%May 26Aug 26Oct 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

1 pkg affected
🐘codiad/codiad

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects Packagist packages — download data is not available via public APIs for these ecosystems.

Description

components/filemanager/class.filemanager.php in Codiad before 2.8.4 is vulnerable to remote command execution because shell commands can be embedded in parameter values, as demonstrated by search_file_type.

Affected Packages

1 total 1 fixed
EcosystemPackageVulnerable rangeFix
🐘Packagistcodiad/codiadall versions2.8.3composer require codiad/codiad:^2.8.3

Affected Products

1 product · 1 configurations
Application
codiadcodiad
≤ 2.8.3
range
Exploits & PoCs
1

Research use only. For defensive security, authorized penetration testing, and academic research only. Never execute exploit code against systems without explicit written authorization.

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for codiad/codiad, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update codiad/codiad to 2.8.3 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2017-11366 is resolved across your whole dependency graph.

  3. Workarounds

    Stop passing untrusted input into the interpreter or shell: call the affected binary with an argument array rather than a composed command string, reject anything outside a strict allowlist of expected values, and run the component under an account that cannot reach beyond the work it legitimately does.

Frequently Asked Questions

components/filemanager/class.filemanager.php in Codiad before 2.8.4 is vulnerable to remote command execution because shell commands can be embedded in parameter values, as demonstrated by search_file_type.
O3 Security · Impact-Aware SCA

Is CVE-2017-11366 in your dependencies?

Find it across Packagist, including transitive dependencies.

CVE-2017-11366: codiad — Fixed in 2.8.3