NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
📦
📦 npm
Not in CISA KEV
CRITICAL severity

CVE-2017-1001003 — mathjs

CRITICALFix: josdejong/mathjs@a60f3c8

CVE-2017-1001003 is a critical-severity (CVSS 9.8) CWE-88 vulnerability in mathjs. A fix is available for mathjs — see the affected versions and patch details below.

Arbitrary Code Execution in mathjs

Also known asGHSA-pv8x-p9hq-j328
Published
Updated
Affected
1 pkg
Patched
1 / 1
Exploits
None indexed
Exploitation data as of Oct 23, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

EPSS Exploitation Probability

via FIRST.org ↗
1.7%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs77th percentile — riskier than 77% of all scored CVEsHighest risk
0.00%0.73%1.46%2.19%0.5%1.7%Apr 26Aug 26Oct 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

1 pkg affected

How broadly this vulnerability is actually deployed: weekly install volume shows current usage, and reverse-dependency count shows how many other packages break if it stays unpatched.

3Kother npm packages depend on this — each one inherits the vulnerability until it's patched upstream
mathjsnpm
2.4Mdownloads / week

Description

math.js before 3.17.0 had an issue where private properties such as a constructor could be replaced by using unicode characters when creating an object.

Recommendation

Upgrade to version 3.17.0 or later.

Affected Packages

1 total 1 fixed
EcosystemPackageVulnerable rangeFix
📦npmmathjsall versions3.17.0npm install mathjs@3.17.0

Affected Products

1 product · 1 configurations
Application
mathjsmathjs_project
< 3.17.0
range

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for mathjs, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update mathjs to 3.17.0 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2017-1001003 is resolved across your whole dependency graph.

  3. Workarounds

    If you can't upgrade right away: gate or disable the affected feature, validate untrusted input at the boundary, and avoid passing attacker-controlled data into the vulnerable path. O3's runtime protection blocks exploitation in production as an interim safeguard until the upgrade lands.

Frequently Asked Questions

math.js before 3.17.0 had an issue where private properties such as a constructor could be replaced by using unicode characters when creating an object. ## Recommendation Upgrade to version 3.17.0 or later.
O3 Security · Impact-Aware SCA

Is CVE-2017-1001003 in your dependencies?

Find it across npm, including transitive dependencies.

CVE-2017-1001003: mathjs — Fixed in 3.17.0