NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
🐘
🐘 Packagist
Not in CISA KEV
MEDIUM severity

CVE-2017-1000510 — croogo

MEDIUM

CVE-2017-1000510 is a medium-severity (CVSS 5.4) Cross-site Scripting (XSS) vulnerability in croogo/croogo. 1 public exploit or proof-of-concept reference is indexed, so weaponization risk is real. A fix is available for croogo/croogo — see the affected versions and patch details below.

Cross site scripting in Croogo

Published
Updated
Affected
1 pkg
Patched
1 / 1
Exploits
1 known
Exploitation data as of Oct 24, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

EPSS Exploitation Probability

via FIRST.org ↗
0.8%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs55th percentile — riskier than 55% of all scored CVEsHighest risk
0.00%0.42%0.85%1.27%0.3%0.8%Apr 26Aug 26Oct 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

1 pkg affected
🐘croogo/croogo

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects Packagist packages — download data is not available via public APIs for these ecosystems.

Description

Croogo version 2.3.1-17-g6f82e6c contains a Cross Site Scripting (XSS) vulnerability in Page name that can result in execution of javascript code.

Affected Packages

1 total 1 fixed
EcosystemPackageVulnerable rangeFix
🐘Packagistcroogo/croogoall versions4.0.0composer require croogo/croogo:^4.0.0

Affected Products

1 product · 1 configurations
Application
croogocroogo
1 version
2.3.1-17-g6f82e6c
Exploits & PoCs
1

Research use only. For defensive security, authorized penetration testing, and academic research only. Never execute exploit code against systems without explicit written authorization.

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for croogo/croogo, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update croogo/croogo to 4.0.0 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2017-1000510 is resolved across your whole dependency graph.

  3. Workarounds

    Escape or sanitise the affected output on the server side rather than relying on client-side filtering, and add a Content-Security-Policy that blocks inline script execution so injected markup cannot run even if it reaches the page.

Frequently Asked Questions

Croogo versions before 4.x contain a Cross Site Scripting (XSS) vulnerability in Page name that can result in execution of javascript code.
O3 Security · Impact-Aware SCA

Is CVE-2017-1000510 in your dependencies?

Find it across Packagist, including transitive dependencies.

CVE-2017-1000510: croogo XSS — Fixed in 4.0.0