CVE-2017-1000491 is a medium-severity (CVSS 6.1) Cross-site Scripting (XSS) vulnerability in shiba. A fix is available for shiba — see the affected versions and patch details below.
Shiba vulnerable to XSS leading to code execution
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
How urgent is this, really
Where this sits among everything scored
Real-World Exposure
How broadly this vulnerability is actually deployed: weekly install volume shows current usage, and reverse-dependency count shows how many other packages break if it stays unpatched.
shibanpmDescription
Shiba markdown live preview app version 1.1.0 is vulnerable to XSS which leads to code execution due to enabled node integration.
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| 📦npm | shiba | all versions | 1.1.1npm install shiba@1.1.1 |
Affected Products
shibashiba_projectDetection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for shiba, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update shiba to 1.1.1 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2017-1000491 is resolved across your whole dependency graph.
Workarounds
Escape or sanitise the affected output on the server side rather than relying on client-side filtering, and add a Content-Security-Policy that blocks inline script execution so injected markup cannot run even if it reaches the page.
Frequently Asked Questions
Is CVE-2017-1000491 in your dependencies?
Find it across npm, including transitive dependencies.