NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
☕
☕ Maven
Not in CISA KEV
CRITICAL severity

CVE-2017-1000487 — plexus-utils

CRITICALFix: codehaus-plexus/plexus-utils@b38a1b3

CVE-2017-1000487 is a critical-severity (CVSS 9.8) OS Command Injection vulnerability in org.codehaus.plexus:plexus-utils. A fix is available for org.codehaus.plexus:plexus-utils — see the affected versions and patch details below.

OS Command Injection in Plexus-utils

Also known asGHSA-8vhq-qq4p-grq3SNYK-JAVA-ORGCODEHAUSPLEXUS-31522
Published
Updated
Affected
1 pkg
Patched
1 / 1
Exploits
None indexed
Exploitation data as of Nov 5, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

EPSS Exploitation Probability

via FIRST.org ↗
6.5%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs94th percentile — riskier than 94% of all scored CVEsHighest risk
5.99%6.76%7.53%8.30%7.8%6.5%May 26Sep 26Nov 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

1 pkg affected
☕org.codehaus.plexus:plexus-utils

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects Maven packages — download data is not available via public APIs for these ecosystems.

Description

Plexus-utils before 3.0.16 is vulnerable to command injection because it does not correctly process the contents of double quoted strings.

Affected Packages

1 total 1 fixed
EcosystemPackageVulnerable rangeFix
☕Mavenorg.codehaus.plexus:plexus-utilsall versions3.0.16org.codehaus.plexus:plexus-utils:3.0.16

Affected Products

2 products · 4 configurations
Application
plexus-utilscodehaus-plexus
< 3.0.16
range
OS
debian linuxdebian
3 versions
7.08.09.0

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for org.codehaus.plexus:plexus-utils, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update org.codehaus.plexus:plexus-utils to 3.0.16 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2017-1000487 is resolved across your whole dependency graph.

  3. Workarounds

    Stop passing untrusted input into the interpreter or shell: call the affected binary with an argument array rather than a composed command string, reject anything outside a strict allowlist of expected values, and run the component under an account that cannot reach beyond the work it legitimately does.

Fixing This On Your OS

If you run this on a Linux distribution, patch through your package manager against the distro's own security advisory below — it tracks the exact backported fix for your release, which can ship on a different timeline (and sometimes a different severity) than the upstream project.

Red HatModerate

This issue affects the versions of plexus-utils as shipped with Red Hat Enterprise Linux 7 as well as Red Hat Satellite 6.0 and 6.1. Red Hat Satellite 6.2 and later do not ship plexus-utils, as such they are not affected by this vulnerability. Red Hat Product Security has rated this issue as having Moderate security…

ProductFixed inAdvisory
Red Hat JBoss A-MQ 6.3plexus-utilsRHSA-2018:1322

Frequently Asked Questions

Plexus-utils before 3.0.16 is vulnerable to command injection because it does not correctly process the contents of double quoted strings.
O3 Security · Impact-Aware SCA

Is CVE-2017-1000487 in your dependencies?

Find it across Maven, including transitive dependencies.

CVE-2017-1000487: plexus-utils — Fixed in 3.0.16