CVE-2017-1000442 is a medium-severity (CVSS 5.4) Cross-site Scripting (XSS) vulnerability in passbolt/passbolt_api. A fix is available for passbolt/passbolt_api — see the affected versions and patch details below.
Passbolt API is vulnerable to XSS in the url field on the password workspace grid and sidebar
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
How urgent is this, really
Where this sits among everything scored
Real-World Exposure
passbolt/passbolt_apiReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects Packagist packages — download data is not available via public APIs for these ecosystems.
Description
Passbolt API version 1.6.4 and older are vulnerable to a XSS in the url field on the password workspace
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| 🐘Packagist | passbolt/passbolt_api | all versions | 1.6.5composer require passbolt/passbolt_api:^1.6.5 |
Affected Products
passbolt apipassboltDetection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for passbolt/passbolt_api, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update passbolt/passbolt_api to 1.6.5 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2017-1000442 is resolved across your whole dependency graph.
Workarounds
Escape or sanitise the affected output on the server side rather than relying on client-side filtering, and add a Content-Security-Policy that blocks inline script execution so injected markup cannot run even if it reaches the page.
Frequently Asked Questions
Is CVE-2017-1000442 in your dependencies?
Find it across Packagist, including transitive dependencies.