Your RSA-2048 keys break in 2030. Find every one of them before attackers do.
☕
☕ Maven
CISA KEV · ACTIVELY EXPLOITED
CRITICAL severity

CVE-2017-1000353 — jenkins-core

CRITICALFix: jenkinsci/jenkins@36b8285

CVE-2017-1000353 is a critical-severity (CVSS 9.8) Deserialization of Untrusted Data vulnerability in org.jenkins-ci.main:jenkins-core. It is in CISA's Known Exploited Vulnerabilities catalog (added 2025-10-02) — treat it as actively exploited and patch now. A fix is available for org.jenkins-ci.main:jenkins-core — see the affected versions and patch details below.

Deserialization of Untrusted Data in Jenkins

Also known asGHSA-26wc-3wqp-g3rp
Published
Updated
Affected
2 pkgs
Patched
2 / 2
Exploits
11 known
Exploitation data as of Oct 26, 2026 · OSV.dev, NVD, CISA KEV, FIRST.org (EPSS)

Exploitation Status

Actively exploited in the wild

  • Confirmed by CISA's Known Exploited Vulnerabilities catalog on 2025-10-02. Federal agencies were required to remediate by 2025-10-23.
  • CISA assesses this as automatable — exploitation doesn’t require manual, per-target effort, which raises the odds of mass scanning and opportunistic attacks.
  • A successful exploit gives an attacker total control of the affected component, not partial access.

Exploitation and automatability from CISA (KEV catalog and SSVC triage) for CVE-2017-1000353.

EPSS Exploitation Probability

via FIRST.org ↗
99.7%probability of exploitation in next 30 days
Very High Risk0.00%
Lower risk than most CVEs100th percentile — riskier than 100% of all scored CVEsHighest risk
92.9%95.3%97.6%100.0%94.5%99.7%Apr 26Aug 26Oct 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

CVE-2017-1000353 by exploitation likelihood (EPSS) against impact (CVSS). In the shaded patch-first corner (EPSS 50%+, CVSS 7.0+).

Where this sits among everything scored

Of 396,257 CVEs with a current EPSS score, this one falls in the ≥ 90% band (highlighted). Counts from FIRST.org, log-scaled.

Real-World Exposure

2 pkgs affected
☕org.jenkins-ci.main:jenkins-core☕org.jenkins-ci.main:jenkins-core

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects Maven packages — download data is not available via public APIs for these ecosystems.

Description

Jenkins versions 2.56 and earlier as well as 2.46.1 LTS and earlier are vulnerable to an unauthenticated remote code execution. An unauthenticated remote code execution vulnerability allowed attackers to transfer a serialized Java SignedObject object to the Jenkins CLI, that would be deserialized using a new ObjectInputStream, bypassing the existing blacklist-based protection mechanism. We're fixing this issue by adding SignedObject to the blacklist. We're also backporting the new HTTP CLI protocol from Jenkins 2.54 to LTS 2.46.2, and deprecating the remoting-based (i.e. Java serialization) CLI protocol, disabling it by default.

Affected Packages

2 total 2 fixed
EcosystemPackageVulnerable rangeFix
☕Mavenorg.jenkins-ci.main:jenkins-core≥ 2.50&&< 2.572.57org.jenkins-ci.main:jenkins-core:2.57
☕Mavenorg.jenkins-ci.main:jenkins-coreall versions2.46.2org.jenkins-ci.main:jenkins-core:2.46.2

Affected Products

2 products · 3 configurations
Application
jenkinsjenkins
≤ 2.46.1
range
Application
communications cloud native core automated test suiteoracle
1 version
1.9.0
Exploits & PoCs
11

Research use only. For defensive security, authorized penetration testing, and academic research only. Never execute exploit code against systems without explicit written authorization.

EDB-41965dosjava

CloudBees Jenkins 2.32.1 - Java Deserialization

by SecuriTeam · May 5, 2017

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for org.jenkins-ci.main:jenkins-core, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update org.jenkins-ci.main:jenkins-core to 2.57 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2017-1000353 is resolved across your whole dependency graph.

  3. Workarounds

    Do not deserialise data from untrusted sources: where the format allows it, restrict deserialisation to an explicit allowlist of expected types, and prefer a data-only format (JSON, Protobuf) over one that can reconstruct arbitrary objects until you can upgrade.

Frequently Asked Questions

Jenkins versions 2.56 and earlier as well as 2.46.1 LTS and earlier are vulnerable to an unauthenticated remote code execution. An unauthenticated remote code execution vulnerability allowed attackers to transfer a serialized Java `SignedObject` object to the Jenkins CLI, that would be deserialized using a new `ObjectInputStream`, bypassing the existing blacklist-based protection mechanism. We're fixing this issue by adding `SignedObject` to the blacklist. We're also backporting the new HTTP CLI protocol from Jenkins 2.54 to LTS 2.46.2, and deprecating the remoting-based (i.e. Java serializati
O3 Security · Impact-Aware SCA

Is CVE-2017-1000353 in your dependencies?

Find it across Maven, including transitive dependencies.

CVE-2017-1000353: jenkins-core RCE (Critical 9.8, KEV)