CVE-2017-1000244 — favorite
HIGHCVE-2017-1000244 is a high-severity (CVSS 8.8) Cross-Site Request Forgery (CSRF) vulnerability in org.jvnet.hudson.plugins:favorite. A fix is available for org.jvnet.hudson.plugins:favorite — see the affected versions and patch details below.
Jenkins Favorite Plugin vulnerable to Cross-Site Request Forgery
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
How urgent is this, really
Where this sits among everything scored
Real-World Exposure
org.jvnet.hudson.plugins:favoriteReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects Maven packages — download data is not available via public APIs for these ecosystems.
Description
Jenkins Favorite Plugin version 2.2.0 and older is vulnerable to CSRF resulting in data modification.
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| ☕Maven | org.jvnet.hudson.plugins:favorite | all versions | 2.3.2org.jvnet.hudson.plugins:favorite:2.3.2 |
Affected Products
favoritejenkinsDetection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for org.jvnet.hudson.plugins:favorite, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update org.jvnet.hudson.plugins:favorite to 2.3.2 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2017-1000244 is resolved across your whole dependency graph.
Workarounds
If you can't upgrade right away: gate or disable the affected feature, validate untrusted input at the boundary, and avoid passing attacker-controlled data into the vulnerable path. O3's runtime protection blocks exploitation in production as an interim safeguard until the upgrade lands.
Frequently Asked Questions
Is CVE-2017-1000244 in your dependencies?
Find it across Maven, including transitive dependencies.