NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
💧
💧 Hex
Not in CISA KEV
CRITICAL severity

CVE-2017-1000212 — alchemist.vim

CRITICALFix: tonini/alchemist-server#16

CVE-2017-1000212 is a critical-severity (CVSS 9.8) remote code execution vulnerability in alchemist.vim. A fix is available for alchemist.vim — see the affected versions and patch details below.

alchemist.vim vulnerable to remote code execution

Published
Updated
Affected
1 pkg
Patched
1 / 1
Exploits
None indexed
Exploitation data as of Oct 31, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

EPSS Exploitation Probability

via FIRST.org ↗
2.9%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs87th percentile — riskier than 87% of all scored CVEsHighest risk
1.37%2.04%2.71%3.38%1.9%2.9%May 26Aug 26Oct 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

1 pkg affected
💧alchemist.vim

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects Hex packages — download data is not available via public APIs for these ecosystems.

Description

Elixir's vim plugin, alchemist.vim is vulnerable to remote code execution in the bundled alchemist-server. A malicious website can execute requests against an ephemeral port on localhost that are then evaluated as elixir code.

Affected Packages

1 total 1 fixed
EcosystemPackageVulnerable rangeFix
💧Hexalchemist.vimall versions1.3.2mix deps.update alchemist.vim

Affected Products

1 product · 1 configurations
Application
alchemist-serveralchemist-elixir
all

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for alchemist.vim, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update alchemist.vim to 1.3.2 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2017-1000212 is resolved across your whole dependency graph.

  3. Workarounds

    If you can't upgrade right away: gate or disable the affected feature, validate untrusted input at the boundary, and avoid passing attacker-controlled data into the vulnerable path. O3's runtime protection blocks exploitation in production as an interim safeguard until the upgrade lands.

Frequently Asked Questions

Elixir's vim plugin, alchemist.vim is vulnerable to remote code execution in the bundled alchemist-server. A malicious website can execute requests against an ephemeral port on localhost that are then evaluated as elixir code.
O3 Security · Impact-Aware SCA

Is CVE-2017-1000212 in your dependencies?

Find it across Hex, including transitive dependencies.

CVE-2017-1000212: alchemist.vim RCE — Fixed in 1.3.2